0
$\begingroup$

tried to make tank’s track using curve, but it looks like this, have tried to rotate, apply transformation, modifying the array parameter and change the parameter axis. But nothing seems work, how do I make it work? enter image description here

$\endgroup$
2
  • $\begingroup$ Welcome. Please use a title that matches the content of the question. It should be descriptive but succinct, unique and identifying, summarizing the issue in such way that anyone searching for a similar problem may easily find it. Use the edit link above, remove anything superfluous, avoid words like "this","issue with" or "question about". Remember, your title is the first thing potential visitors will see, answers you get depend heavily on how inviting it is. See "What is the problem of asking “How do I do this?"" $\endgroup$ Oct 3, 2023 at 5:05
  • 1
    $\begingroup$ pls provide blend file because you showed us nearly no settings you made. thx. $\endgroup$
    – Chris
    Oct 3, 2023 at 5:36

1 Answer 1

1
$\begingroup$

When loading mesh(es) along a curve, it's preferable to first apply transforms on both objects (rotation, scale, position), and the most important that you obviously didn't do here : make sure that both object's origin is at the same exact position.

1- Select the curve, apply transforms (Ctrl+A), set origin to where you want it, set cursor to selected. 2- Select your tank's track mesh, apply transforms, set origin to 3D cursor.

Now both objects will behave logically and your mesh will follow along the curve. If you still have weird results, check your mesh in edit mode, avoid moving it in object mode anymore.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged .