0
$\begingroup$

Brief overview

I'm currently working with a research project which is simulating particles (using Molecular+) within a hollow structure. Due to confidentiality, there are some aspects of the project which I am not able to share, but I can describe it generically.

The particles are colliding with the hollow structure, as it is vibrating. Due to the physical limitations of Blender and due to lack of information generally, I resorted to apply 'Wind' force fields to help 'coax' the particle towards where they need to be in the structure. These force fields are placed strategically throughout the structure to basically pave a path towards the goal. These force fields have a maximum distance of effect, and are only applied on the positive Z-direction of their origins.

There is a particle emitter at the 'start' of the structure, for which the particles are immediately 'caught' by the force fields.

Here's the issue:

When the particles have reached their goal, they are outside the max distance of any of the force field objects, yet somehow are affected by some unknown force. This is noticeable because the particles have a velocity when they reach their goal, which then is turned successively towards a direction that is not gravity. I have scoured the Collection Explorer for any hiding force field objects unaccounted for, but there are none.

Does anyone know what could be wrong here?

I should be able to give additional details upon request.

$\endgroup$
2
  • $\begingroup$ Hi, Iroh, this is going to be very hard to answer without a specific example of the behaviour you seek. Despite your explanation, there's a very high chance that answers will be to the wrong question. Are you sure you can't produce a minimal, toy version of the problem, in essence, without revealing the entire project? $\endgroup$
    – Robin Betts
    Oct 3, 2023 at 7:01
  • $\begingroup$ It turned out that the max distance is determined by another option, not documented at Blender itself, is doing what I want. In the setting for falloff, there's a subtab called "radial" and setting the max distance there worked. I'm not sure why, but it at least the issue is solved. $\endgroup$
    – Iroh
    Oct 4, 2023 at 7:19

1 Answer 1

0
$\begingroup$

It turned out that the max distance is determined by another option, not documented at Blender itself.

It is doing what I want. In the setting for falloff, there's a sub-tab called "Radial" and setting the max distance there, worked.

I'm not sure why, but it at least the issue is solved.

$\endgroup$
1
  • $\begingroup$ Hi, Iroh, Glad you have a fix. If eventually, when you're allowed to, you tick your own answer, accepting it, then we'll recognize the question as 'closed'. $\endgroup$
    – Robin Betts
    Oct 4, 2023 at 7:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .