I recalculate the normels on "All" the objects to make sure they were facing outwards on the meshes, while that fixed the scattering effect it causes another issue. The three branch objects are all placed in collections which I have in "Render As", but they seem to be clipping in through the mesh surface causing those white dots you see. This happen when I clicked on "Object Rotation" I only did that because the branches were twisting weirdly around the tree stem. Do I just uncheck "Object Rotation" and tweak the settings until I get it right if so, how? Or is there a way to push the objects out of the mesh?enter image description here


1 Answer 1

  • In Edit mode rotate branches in +Z direction
  • under Particle Properties enable Rotation > Normal
  • under Particle Properties > Collection uncheck Object Rotation

enter image description here

Note: One of the confusion with particles is object orientation, where the particle object should be oriented in positive Y direction to be used in emitter's Normal direction. That looks weird even more in situations like if instance is something like a tree model to be emitted as a forest ... correctly orientated mesh tree looks like it is laying on a ground. I'm not sure what is behind this ... probably it comes from unification with other apps (that is not natural for blender concepts :) ...where +Y is used for up direction and +Z for depth ... but blender is using +Y for depth direction and +Z for height.

  • $\begingroup$ The first two I understand but the last one I couldn't get can you please explain further? $\endgroup$
    – Stephen
    Oct 1 at 22:23
  • $\begingroup$ Edited ... I hope it is more clear now :) $\endgroup$
    – vklidu
    Oct 2 at 7:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .