4
$\begingroup$

I want to import Sketchup models in blender. For that, I tried exporting models form sketchup in various formats using the built in exporter in Sketchup followed by import in blender. The model looked fine in Sketchup but when I imported it in blender using "Import Model", the model's body mesh gets triangulated. This is making the model useless for me as it is very hard to work with in blender. Especially circular parts gets triangulated to a number of portions and are very hard to scale/ rotate etc. Please suggest how should I import/export the model correctly.

In sketchup Sketchup

In Blender enter image description here

I tried the procedure above for

  1. Collada
  2. obj
  3. 3dS Max

The model looks same with all formats.

Link to sketchup model: http://sketchup.google.com/3dwarehouse/details?mid=a91cb0fd50d4b2cc5599acd1021b314d&prevstart=0

$\endgroup$
  • 2
    $\begingroup$ perhaps link to the sketchup model, it is difficult to see if there is anything wrong with this import (and of relevance to Blender.StackExchange) . sketchup internally has n-gons and it seems to default to triangulating the meshes in the export process -- which is a valid thing to do. $\endgroup$ – zeffii Sep 20 '13 at 9:00
  • 1
    $\begingroup$ In the exporter settings, there might have been an option to triangulate faces. $\endgroup$ – iKlsR Sep 20 '13 at 12:56
  • $\begingroup$ Models for games must be triangulated at som point. I see no distorsion, only triangulation. ITs not pretty but should be workable. $\endgroup$ – Gunslinger Sep 20 '13 at 15:38
  • $\begingroup$ possible duplicate of Import SketchUp ".skp" files $\endgroup$ – gandalf3 Sep 20 '13 at 20:18
  • $\begingroup$ Its doing triangulation without providing any option. Triangulated is workable but if we can somehow avoid triangulation, it could be much easier to work with. Especially circular parts are very hard to work with.. $\endgroup$ – simar Sep 23 '13 at 10:47
3
$\begingroup$

You can't (at least - not the way you want)

SketchUp very cleverly abstracts away the underlying geometry by rendering all connected faces on the same plane as one surface (unless you tell it not to). With this visual abstraction SketchUp allows surfaces to have gaps.

Blender's geometry model, known as BMesh, treats surfaces differently, it has a model of Tris, Quads and Ngons. BMesh does not allow holes in an Ngon (by design). By extension of this fact, you won't have exactly the same representation in Blender as you would in SketchUp for the same model. Blender won't magically abstract connected faces on the same plane into surfaces the way SketchUp does.

img here

The loaded geometry will be correct, but in edit mode you will see the real geometry the way it exists in the .dae.

Blender is designed to let you edit the underlying geometry. it is a true polygon modeller. Ngon support with BMesh is a relatively recent development -- before that it was quads and tris only.

What you could do is:

  • enter Edit Mode for each object
  • select all
  • Delete -> Limited Dissolve

You will get a mesh that is perhaps more convenient.

Another option is to press Alt+J in edit mode, wich will transform all the triangles into quads.

enter image description here

$\endgroup$
  • $\begingroup$ You dont have to do this manually, See: Mesh -> Delete -> Limited Dissolve $\endgroup$ – ideasman42 Sep 24 '13 at 5:15
  • $\begingroup$ awesome thx for Limited Dissolve I never know what is is for,just recenlly I started to work with game characters etc $\endgroup$ – Utas Sep 26 '13 at 12:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.