1
$\begingroup$

[when a keyframe is duplicatedbefore the duplicate keyframeFrame 120 is a duplicate of frame 119 just like 114 and 115 but the grayed bar is not showing like it's supposed to between frame 119 and 120.

How do I get it to show back? Even other duplicates I make now don't have the bars like before. I also noticed the problem started after I was done editing F-curves from the graph editor.

Image of the problem

$\endgroup$
2
  • 1
    $\begingroup$ Hello and welcome. Rather than take photos of your monitor post actual screenshots instead, see How to take a screenshot. Photos are harder to read because we have to look past external interferences (like reflections, smudges or Moiré patterns) and guess if we are looking at hardware issues such as a malfunctioning display or connections, a software level issue like driver malfunction or glitch, or actual artifacts or issues with the model itself. $\endgroup$ Sep 28 at 21:02
  • $\begingroup$ "I also noticed the problem started after I was done editing F-curves from the graph editor." Well, then it would have been good to also show a (proper) screenshot of the Graph Editor. But I guess that's exactly where the problem lies and @L0Lock has provided an answer for this case. $\endgroup$ Sep 29 at 8:13

1 Answer 1

4
$\begingroup$

If the bar is gone, it means they are not identical keys anymore.

Editing the graph, even if you don't change the keyframe's value and frame, change the keyframe's handles, and therefore isn't a duplicate of its original.

demo gif

$\endgroup$
2
  • $\begingroup$ I understand that editing the curve of a keyframe makes it different from its duplicate keyframe. The keyframe I edited the curve is one frame 117. 120 however is a duplicate of 119 but it doesn't show the connecting bar. $\endgroup$ Sep 29 at 21:53
  • $\begingroup$ I couldn't figure out how to add pictures here so I added a picture in the main question. In the picture, frame 124 is a duplicate of frame 123 and there is still no connecting bar that's what my problem is. The values for the two keyframe look the same but the bar is just not showing and I don't understand why that is. $\endgroup$ Sep 29 at 22:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .