I was wondering how you could avoid multiple shadows when using multiple light sources. I know that you can simply uncheck the "cast shadow" on the lights that you won't making shadows but that's not gonna work, then the scene looks washed out and no shadows; I guess the brightness of the light get rid of the shadows. This is a huge issue when you're trying to render products and stuff.

enter image description here

  • $\begingroup$ Hello and welcome. 3D world is not like real world, which means that most of the time you have to fake things to make it look like in real life. It could be that you need to add multiple lights with different settings to make it look like you are using just one light like in real life. One thing that you could take advantage of are the HDRI light sources and try to make it look correctly even if you need more than one light source, don't be afraid of testing different approaches. Lastly, this question looks like option based, so you could try other forum too like blenderartists or reddit $\endgroup$
    – Emir
    Commented Sep 27, 2023 at 17:08

1 Answer 1


Softer Fill Light

I've found that the best way to eliminate multiple shadows is to use softer lighting. You can do this by increasing the size of the light.

I generally use Area Lights for soft fill lighting instead of Point Lights.

Try switching some of your fill lights to Area Lights and increase the size. You can leave one light source small and sharp if you still want one hard shadow. I've included an example below.

Two Point Lights casting two shadows:

A chair in Blender casting two shadows both from point lights

One shadow is softened by switching to Area Light:

A chair in Blender with one point light and one area light casting one shadow.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .