1
$\begingroup$

Ever since I downloaded Blender version 3.6, I can't use the knife tool without seeing everything in x ray mode. The moment I complete my cut and click anywhere else, the mode goes back to solid, but the problem is that when I'm trying to cut a complicated mesh, I see all the vertices on the back and can't see what I'm cutting. This problem has nothing to do with Machin3tools which I do not have at all as an add on.

I added an image below as an example - just after opening blender with factory settings and doing subdivide on the cube a few times, then I just pressed K to get the knife tool and it immediately changed to x-ray mode. I'm thinking I may have the same shortcut for both for some reason, so I'll tinker with that and post if I find anything.

enter image description here

I'm adding the knife tool options window here - I saw there was an x-ray option that was checked, but unchecking it doesn't solve my problem either.enter image description here

$\endgroup$
5
  • $\begingroup$ I can't reproduce this.. if C > Cut Trough is activated, sure, the knife tool indicates the vertices it's going to create in edges I can't see.. but that's not quite X-ray mode... $\endgroup$
    – Robin Betts
    Sep 27, 2023 at 6:44
  • $\begingroup$ any add-ons installed that could cause this? Have you tried to start Blender with factory settings? $\endgroup$
    – Blunder
    Sep 27, 2023 at 18:54
  • 1
    $\begingroup$ Can't reproduce it either. As mentioned before, of course it shows the hidden points where it cuts through the mesh when Cut Through is activated, but that is something (and looks) different than X-Ray mode. Would it be asked too much if you would show at least one screenshot of how it appears in your Blender? Otherwise it is just guessing if there really is an issue or it is just a misinterpretation on your behalf - please include the options you have activated on the Knife tool (like Cut Through for example). $\endgroup$ Sep 27, 2023 at 19:25
  • $\begingroup$ I tried to check if toggle x-ray and the knife tool had the same hot key, but they don't. I'm even getting the darn x-ray mode when I select a single vertex in edit mode. Really no idea what's happening. $\endgroup$
    – Marek R.
    Oct 2, 2023 at 19:06
  • $\begingroup$ I'm having the same issue since 4.0. Changing GPU settings sadly didn't helps. Here's a screen recording of the issue if it helps imgur.com/f9Q00fB $\endgroup$ Dec 20, 2023 at 16:53

1 Answer 1

0
$\begingroup$

I've had same issue on MacBook Air. Have fixed it with changing GPU backend settings under Preferences -> System. Hope that helps.

$\endgroup$
1
  • $\begingroup$ For the time being I just downloaded an earlier version of blender and that completely solved my issue. I'm not needing any newer features anyway, so that works for me. It also, for the umpteenth time, reminds me that upgrades usually do more harm than good :) $\endgroup$
    – Marek R.
    Dec 21, 2023 at 22:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .