0
$\begingroup$

When I export my character (with several meshes: body, eyes, eyebrows etc.), some - though not all of my meshes, end up having their shape keys as animation tracks. As seen through the Godot Import dialogue at least. When animations are being played, they prevent me from manipulating the blendshapes directly, since the animation tracks keep setting them to 0.

I'm not sure if this is a godot issue or a blender issue, but I thought I'd try asking here.

Thanks in advance.

$\endgroup$

1 Answer 1

1
$\begingroup$

If Drivers have been created, they will cause blender to export them as animations, so deleting the drivers solves the issue.

In my case, I was only using the drivers to more easily preview Shape Keys that need to be synced between different meshes (body, eyes, eyebrows etc.)

$\endgroup$
1
  • 1
    $\begingroup$ Good find here. Note there are also animation export options in the right-side panel of the glTF export dialog. Expand the "Animations" section and there are options for shape keys in there. Not sure if that helps in your case. $\endgroup$
    – emackey
    Sep 27, 2023 at 13:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .