This is my 1st post here. Im very new to Blender, so im trying to figure out as much as i can via this site, and youtube. I've been trying to create a GN setup like a magnetic field of rings, and while that part went fine, I started running into issues when i tried to attach arrows to the field lines, and have them slide along the lines.

The main source for moving the instanced arrows along the lines was this video... https://www.youtube.com/watch?v=-Gi3BbKA3cY

... and while it works fine for a single curve, it stops working when multiple curves are involved. Iv tried hooking things up in different ways, but I dont know enough about GN to get this to work.

Iv made a simplied blend file to attach here, that removed a bunch of the initial cloning of the field rings, and simply replaced that with a curve that has 2 individual curves as its base geometry. This replicated the problem or trying to use clones of the source curve... the arrows only ever stick/follow 1 of them. There are some group controls in the GN modifier. The scene is currently set to use a viewer in the middle of the node graph where the clones are still respecting both curves, however, without the moving along the curve functionality. If you view the graph at the end of chain, where the clones are moving, you will see how the clones are forced to use only 1 curve (oh, and also lose their along-curve orientation).

If anyone has some insight on this, it would be greatly appreciated.

  • $\begingroup$ The creator of the above linked video was kind enough to comment back to me very quickly and pointed out a working setup in another of his videos. Apparently i was missing the "curve index" input from the Sample Curve node (i had just left mind at the default 0), but since his node setup in the other video was completely different, it was pretty much a rebuild. For those interested, this is the video showing instances distributed, and offset-able, across multiple curves.... youtube.com/watch?v=gCB3MEGUUjI $\endgroup$
    – Eikon
    Sep 24 at 21:10


You must log in to answer this question.

Browse other questions tagged .