2
$\begingroup$

I want to make my world color in my animation blue, to mirror the sky, but it makes all of my meshes colored blue in the render mode. I'm using version 3.2.2. My goal is to have the meshes not affected by the sky, while still having it as blue. I still want the meshes to have shadows, just not to be blue.

How do I fix this?

$\endgroup$

2 Answers 2

0
$\begingroup$

Use an Input > Light Path node as a factor in a Mix Shader, use the Is Camera Ray output and choose the Background that will be seen as background and the one that will be reflected:

enter image description here

$\endgroup$
0
0
$\begingroup$

Here is an approach with Compositing. Basically you combine two Render Layers with their own settings through a depth value switch.

The first layer uses Scene, ViewLayer and World settings and we want to render the scene without world color influence. For this layer enable the Depth Pass through View Layer Properties > Passes > Data > Include > Z and remove the world color settings.

The second layer is for rendering the world settings. Setup another view layer ViewLayer_001 where you disable the scene objects and create a new scene Scene.001 where you can install a new world data block World.001 with your world color settings.

Now as you can see in the screenshot, combine these two render layers by testing against the depth value. Just make the value big enough, such it's behind all your scene objects. If that's all too complicated, you can also just add a blue RGB node in the second Image input socket of the Mix node.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .