0
$\begingroup$

I don't want to add it as a plane because then my scene lights affect the image and it's going to be hard to make it follow camera movements.

I saw on Youtube that if you use some nodes you can get the background image for camera to render but it didn't work, perhaps something has changed since then?

$\endgroup$

2 Answers 2

1
$\begingroup$

It should work: make sure to check the "Transparent" Film Render option, and set the background image on camera to "Crop", for a perfect corrispondence with the compositing image.

enter image description here

$\endgroup$
3
  • $\begingroup$ It works on a dummy file but not on my main file, any idea what could be the problem? $\endgroup$ Commented Sep 23, 2023 at 14:31
  • 1
    $\begingroup$ Is the "Compositor" option checked in the rendering properties, post processing tab? $\endgroup$ Commented Sep 24, 2023 at 16:15
  • $\begingroup$ It wasn't, and now it seems to work. Also, to anyone else needing the same help it's not in the Render Properties, it's in the Output Properties $\endgroup$ Commented Sep 24, 2023 at 16:33
0
$\begingroup$

I found a workaround, in Render Layers node there is a small button on the bottom right that says "Render active scene", and that should work if F12 doesn't.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .