0
$\begingroup$

I don't know how else to explain it other than many geometry nodes are suddenly no longer working. The output for any node I add is "Unknown socket value. Either the socket was not used or its value was not logged during the last evaluation."

I have gotten a Set Position and Transform Geometry node to work, but pretty much any input node gives that same error:

value node not working in new file

This worked earlier I swear

Here is screenshot from a file I was working on with functioning geometry nodes but when I make a copy of a working one, it no longer functions:

copy of working node suddenly not working

I have tried a fresh install of the latest version of blender and still no change. I'm wondering if this is some blenderism that I'm not familiar with or if I've finally lost my mind. Search results have yielded no relevant information, any help would be extremely appreciated.

$\endgroup$

1 Answer 1

4
$\begingroup$

Reading the error messages helps to find out what is going on. For example what is going on there with the output of the Value node:

empty socket

"the socket was not used": is there something plugged in there? No. Connect it to something - but it has to be something that is involved in producing something for the Group Output - and try again. Sockets are only evaluated if they contribute to the generated geometry. As you can see below, now it says: "0 (Float)"

productive output

Also the error message on the Object Info node is very clear:

self-referencing

"Geometry cannot be received from the modifier object." In the Object Info node you are self-referencing the object which has the Geometry Nodes modifier on it. You can see the name "Cube" in the node and in the top left of the editor window.

If you want the original geometry from the base object which holds the modifier, you need the Group Input node. The Object Info node is to reference other external objects:

group input vs object info

$\endgroup$
2
  • $\begingroup$ Thanks, I was confused about what caused the nodes to get evaluated but that cleared it up. I will note that I was able to reference the geometry of the object that the node modifier was attached to without issue: i.imgur.com/IuqS7sT.png It does not work with the "self object" node but if you pick it in the "object info" node it works. $\endgroup$
    – Matt Duerr
    Sep 21, 2023 at 17:37
  • $\begingroup$ @MattDuerr In that screenshot, the GN modifier is on the object "hex2.gnode", and the Object Info references the object "hex2". $\endgroup$ Sep 21, 2023 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .