1
$\begingroup$

enter image description here

I'm a beginner and I'm trying the Polygon runway tutorial with a cafe.

After I finished the modeling when I clicked to auto shade smooth at angle 180 some objects turned black. Also if I change the value the objects just remain the same.

Any ideas how to shade it correctly?

here is the file:

$\endgroup$
4
  • $\begingroup$ Can you share the file? blend-exchange.com $\endgroup$
    – taiyo
    Sep 20, 2023 at 19:14
  • $\begingroup$ When you set it to an Angle of 180° all edge angles below this value are considered smooth (unless you mark them as sharp) - which means, there are no edges recognized as sharp. Set the value to something reasonable in the 30° to 60° range (usually the default value of 30° works quite well). $\endgroup$ Sep 21, 2023 at 12:52
  • $\begingroup$ @taiyo I added the file $\endgroup$
    – Alesia
    Sep 21, 2023 at 17:44
  • $\begingroup$ Hi, Alesia, I was going to answer, but others have got there first with the major points. Here's a tweaked version of your file you might want to compare with your own. (Not claiming perfection, just improvement) $\endgroup$
    – Robin Betts
    Sep 22, 2023 at 8:00

2 Answers 2

2
$\begingroup$

You have multiple problems with your model. First the lamp, enable Face Orientation and you will see that the lamp's outside is flipped to the inside (you can also see trouble on the ground mesh, coming later to that):

enter image description here

Select the lamp, go to face edit mode, select all faces and do Mesh > Normals > Recalculate Outside:

enter image description here

Next the little boxes on the roof. Select one, go to vertex edit mode, select all vertices and do right click and Merge Vertices > By Distance. This should merge 4 vertices and fix the shading immediately because the Bevel modifier on that object now can work correctly again. Fix the other roof boxes the same way.

enter image description here

Now the ground, you have some messed up geometry there. Select object Plane, go to face edit mode and select the top face. Switch to vertex edit mode and hit the Del key and select Vertices. The red colored faces should disappear. Plane has still open parts, but they are hidden by other geometry and it fits, that may be ok for you.

enter image description here

Finally, if you inspect the ground further there is a plane Plane.001 which seems unneeded. Also notice the shading of Plane.002 which looks dubious (green arrows). Again there are overlapping vertices. Remove them as shown before and the shading works again.

enter image description here

Side note: Like @GordonBrinkmann points out, you should potentionally use lower values for smooth shading. Your shading works only that way because you have a Bevel modifier applied everywhere.

$\endgroup$
1
  • $\begingroup$ thank you soo much $\endgroup$
    – Alesia
    Sep 22, 2023 at 4:55
1
$\begingroup$

Others have already pointed out your lamp is inside-out, among other things. This is just a supplementary note.

You might consider a tip I picked up from John Dickinson's videos a while back. In User Preferences > Themes > 3D View, set the display of Face Orientation: Front to completely transparent, and Face Orientation: Back to an eye-friendly tint. That means you can leave the Face Orientation overlay switched on all the time while modelling. and see immediately which way your normals are pointing.

enter image description here

Another suggestion might be to add this setting to display wireframe to your Quick menu:

enter image description here

.. which means you can quickly check the effect of modifiers (in particular, Bevel ) on your topology, in Object Mode.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .