I have imported these OBJ and FBX files into a New > General blend file(3.4.1). I gave them their PBR textures and they show black in render but not in Shading Viewport. Shading Viewport, Material > Surface Shading Viewport

Rendered Viewport, Material > Settings

Normals, UVs, Material Settings Normals

Some of the objects show up fine as you can see but I used the same method to set up those materials.

  • 3
    $\begingroup$ Hello and welcome to BSE! maybe overlapping objects or vertices? or not enough lighting? can you share your blend file blend-exchange.com $\endgroup$
    – Harry McKenzie
    Commented Sep 20, 2023 at 5:49

1 Answer 1


This looks like a lightning problem.

As you can see, all the object "showing up" are nearby to each other, with their visibility fading at greater distance from a certain point - the point where supposedly your point light will be.

You can see the effect of your light even in the viewport-shaded view: These objects are brighter than the object being "black" in your render viewport.

Viewport shading by default uses its own (additional) lighting setup so that objects are lighted properly from beginning when you start modeling an object. You have that dropdown-box on the right side of the viewport render selections. In the rendered viewport Scene Lightsand Scene World are enabled, which is the setting that will be used when actually rendering, but you can disable them there too which will lead the scene to be lighted by the vieport lighting settings also used in viewport shading. viewport shading settings

So what your scene need is "just" some proper lightning.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .