1
$\begingroup$

I'm modelling a fictional solar system, and one plan has a very eccentric orbit. So I've set the planet's constraint to "Follow Path." It moves, but not along the orbit. See the screenshot below.

The animation workspace for the system in question

$\endgroup$
2
  • $\begingroup$ Make sure that the origin is at the center of the planet and reset the planet location (alt G) $\endgroup$
    – moonboots
    Commented Sep 17, 2023 at 19:39
  • $\begingroup$ Try zeroing the objects location :) $\endgroup$ Commented Sep 17, 2023 at 19:50

1 Answer 1

1
$\begingroup$

Make sure that the origin is at the center of the planet (RMB > Set Origin > Origin to Geometry, and reset the planet location (altG).

$\endgroup$
5
  • $\begingroup$ I did both of these, just now, and the planet is still offset from its orbit, though the offset is now parallel to the X axis instead of at some weird and variable angle to it. $\endgroup$
    – Whitewings
    Commented Sep 17, 2023 at 21:51
  • $\begingroup$ please share your file (with only the problematic objects): blend-exchange.com $\endgroup$
    – moonboots
    Commented Sep 17, 2023 at 21:56
  • $\begingroup$ Done. blend-exchange.com/b/Yr8M8LlZ $\endgroup$
    – Whitewings
    Commented Sep 17, 2023 at 22:14
  • $\begingroup$ You've keyframed the location of the object, which keeps it far from the scene center, you need to delete these keyframes, then Alt G to bring your object back to the scene center $\endgroup$
    – moonboots
    Commented Sep 17, 2023 at 22:21
  • $\begingroup$ It worked. Thank you! $\endgroup$
    – Whitewings
    Commented Sep 17, 2023 at 22:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .