2
$\begingroup$

How do you zoom past the point where blender stops zooming and still stay in orthogonal mode? I'd like to avoid using ., as it switches to perspective.

I tried all these approaches, but it switches the camera to perspective.

enter image description here

I'd like to avoid the following switch to perspective mode, like this:

enter image description here

$\endgroup$
5
  • $\begingroup$ Unfortunately I do not know how to force Blender to stop zooming in, but when I just zoom in on something for example in Top Orthographic view, pressing Numpad . actually does not switch to Perspective on my PC. Is it only when Blender stopped zooming? $\endgroup$ Sep 14, 2023 at 13:48
  • $\begingroup$ Just saw something - that's not the orthographic view of the 3D Viewport, it is a camera set to Orthographic. Well, that's different, because focusing on an object then takes you out of the camera view. It is very inconvenient to stay in camera view for modeling when you want to zoom in and out of the object. To do this in camera view would only make sense if you would want to zoom in and preserve the perspective - which you do not have with an orthographic camera anyway. So why not use the viewport instead of the camera? Then Blender would not switch between perspective and orthographic. $\endgroup$ Sep 14, 2023 at 13:56
  • $\begingroup$ I use BlenderBIM, that uses cameras as various drawings (floor plans, sections, elevations, etc.). As a workflow, i constantly switch between these various drawings, as I work. As such, it's just more efficient, if I could just stay in this 'camera' mode verses switching out to viewport, every time I have to really zoom into something. $\endgroup$ Sep 15, 2023 at 0:08
  • 1
    $\begingroup$ BlenderBIM is a third-party addon and I have no idea how it works. I don't even really understand what "uses cameras as various drawings" means. Therefore I can't tell if there is no better way with collections, view layers or whatever to achieve similar efficiency. So, if you have to keep up using the camera view, I guess there is no other chance than using Numpad . and Numpad 5 directly afterwards to immediately switch back to Orthographic view. In the Preferences you can disable automatic switching to Perspective when rotating the view, but that does not work with cameras. $\endgroup$ Sep 15, 2023 at 12:37
  • $\begingroup$ FWIW I think you're mistaking camera view and orthogonal view. A camera view (Numpad 0) can be orthogonal or perspective. Pressing Numpad . gets you out of camera view, whether it is orthogonal or perspective is irrelevant to your problem $\endgroup$
    – Gorgious
    Oct 10, 2023 at 9:23

1 Answer 1

2
$\begingroup$

It seems this value is (arbitrarily) hardcoded to 600.

See the relevant docs

You can test this out using the snippet from another answer.

import bpy

zoom = 5
screen = bpy.context.screen
area = next(area for area in screen.areas if area.type == "VIEW_3D")
space = area.spaces.active
region_3d = space.region_3d
region_3d.view_camera_zoom += zoom

It is not uncommon for Blender devs to change hard limits. For example the bevel segment limit has been set to a soft-cap in the past. A thread over on Right Click Select or devtalk to explain the problem might help solving it, usually for these kind of changes it's just a matter of changing a few variables in the property definitions.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .