0
$\begingroup$

I am rendering a png image with a plane transparent background being used a shadow catcher. However, the shadows are not appearing in the png. I have made sure that the shadow catcher is turned on in the visibility settings of the lights.

For reference, the first image is one rendered on a transparent background then placed on a white background in photoshop. The second image is a direct render from blender with the plane not acting as a shadow catcher.

Can anyone figure out why this is happening?

Thanks,

Image rendered with transparent background

Image without shadow catcher

$\endgroup$
3
  • $\begingroup$ "...the shadow catcher is turned on in the visibility settings of the lights"? The plane below the drops(? stones?) needs to be set to Shadow Catcher, not the lights. $\endgroup$ Sep 13, 2023 at 14:27
  • $\begingroup$ Hi Gordon, thanks for the reply. Yes, I meant to say that in addition to the plane being set to shadow catcher, the lights have also been set. Thanks $\endgroup$
    – Johnjoshel
    Sep 15, 2023 at 7:10
  • $\begingroup$ Oh, you do not mean a light in the scene, but in the View Layer Properties under Passes > Light you have enabled Shadow Catcher? Blender has a lot of settings, it is always helpful to explain precisely what you did or even better: show the settings you are talking about. Because if you mean the Passes, this enables a Shadow Catcher output in the Compositor, so you can use the shadow in post processing. In this case it is not directly visible in the render. I've explained that in my answer here: Changes of shadows color $\endgroup$ Sep 15, 2023 at 7:19

0

You must log in to answer this question.

Browse other questions tagged .