1
$\begingroup$

Anyone knows how to apply the bevel modifier after the cutting operation? As the images below show, the cylinder without doing anything on it can be applied the bevel modifier, while the other cylinder which has been applied cut operation can't be applied bevel modifier, anyone know why and how to fix it? Thanks! enter image description here

enter image description here

And I started a simple shape as the commenter moonboots said, and disabled the Clamp Overlap, but I still failed to bevel it after I did a cutting operation on it, I wonder if it can be beveled after the cutting operation. enter image description here

$\endgroup$
5
  • 1
    $\begingroup$ As you've been asked before in your other questions, please add a link to the tutorial you're following and share your Blend file. You can share it via blend-exchange.com following the instructions there to copy the link to it then edit your question and paste the link into it. $\endgroup$
    – John Eason
    Sep 13, 2023 at 9:09
  • $\begingroup$ Hello, could you please share your file? The problem probably comes from the Geometry >Clamp Overlap option of the Bevel modifier that prevent the bevel to happen. If you want this bevel you need to modify the topology $\endgroup$
    – moonboots
    Sep 13, 2023 at 9:11
  • $\begingroup$ blenderbros.com/products/hard-surface-modeling-jumpstart/… Here is the tutorial link, and here is my blender file:<img src="https://blend-exchange.com/embedImage.png?bid=Xp7b5ZwZ" /> $\endgroup$ Sep 13, 2023 at 9:14
  • 1
    $\begingroup$ That's a commercial site so of course we can't see that tutorial without registering. I'll add the link to your Blend file into your question. $\endgroup$
    – John Eason
    Sep 13, 2023 at 9:22
  • 1
    $\begingroup$ It is a paid course, we cannot simply watch it as I said on your other question. And as it seems, I'm quite sure that Clamp Overlap is enabled in the Geometry section of the Bevel modifier. When you cut the cylinder and the result produces vertices/edges very close together, Clamp Overlap keeps the bevel from going too far by beveling only as much as the minimum possible amount of all edges to avoid overlapping, no matter which Amount you have set for the bevel. $\endgroup$ Sep 13, 2023 at 9:26

1 Answer 1

2
$\begingroup$

As you see, your topology here won't allow any correct bevel. You can disable the Clamp Overlap option (which will prevent the faces to overlap) but if you do it you'll have a very bad topology as result:

enter image description here

You'd better begin with a very simple shape that will allow you to easily bevel manually:

enter image description here

enter image description here

Edit: Your new topology is still not good, you have vertices close to each other which will create these overlapping faces, see if I merge them, it fixes the problem, so you should better copy the topology of my model (above):

enter image description here

$\endgroup$
11
  • $\begingroup$ A BTW ... The course OP is following is explicitly 'non sub-d'.. I don't know what its approach is, to this one $\endgroup$
    – Robin Betts
    Sep 13, 2023 at 10:15
  • $\begingroup$ A paid-for course should certainly cover common problems that the OP is asking about here. Maybe there's a Q&A or FAQ section on the course where these issues are addressed? $\endgroup$
    – John Eason
    Sep 13, 2023 at 10:41
  • $\begingroup$ @Robin Betts ah ok I can't watch the tuto without subscribing though $\endgroup$
    – moonboots
    Sep 13, 2023 at 11:21
  • $\begingroup$ The course seems to be free 'in dollars' atm.. I guess Blender Bros reward will in some way be related to the ( perhaps completely fair) promotion of other products. $\endgroup$
    – Robin Betts
    Sep 13, 2023 at 11:28
  • 1
    $\begingroup$ I've edited my answer, your topology is still not good, also are you trying to be non-destructive as much as possible? Sometimes it's not possible and you need to bevel manually $\endgroup$
    – moonboots
    Sep 14, 2023 at 7:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .