I have an object in edit mode. I select multiple vertices. I want to set all of their x positions to the same global position at the same time. The "Transform" panel seems to automatically change into a "Median" mode when multiple vertices are selected, so the operation won't move the vertices to the same global position (instead, the Median).

I read on another post that holding down the Alt key before hitting the Enter key (after setting a value in the X box) should apply the position value to all vertices, but this doesn't work. I'm on a Mac, maybe the modifier key is different.


  • $\begingroup$ what you could do: press M -> merge at center and then enter the coordinates in the transform panel with alt key $\endgroup$
    – Chris
    Sep 12 at 5:05
  • $\begingroup$ scale them to 0 (1 to 3 axis) and set it from N-panel $\endgroup$
    – X Y
    Sep 12 at 5:09
  • $\begingroup$ You can set the pivot point to the Cursor, put the cursor in the origin and then scale the vertices to 0 in the X axis. Or set it to Active, move a vertex to X=0 and then use it to scale all the others to 0 $\endgroup$
    – Cornivius
    Sep 12 at 9:26
  • $\begingroup$ @Cornivius Why so complicated? Since all vertices should be on the same X position, just scale them to 0 on X directly on their mean position without cursor, then move them to the X location by entering the value. $\endgroup$ Sep 12 at 10:18
  • $\begingroup$ Thanks these would work, I'm not sure which to accept - I was surprised that this wasn't a built-in option in the transform panel. I had a very large number of vertices to fix so I ended up making a script for it. $\endgroup$
    – huihygf
    Sep 13 at 19:21


You must log in to answer this question.

Browse other questions tagged .