0
$\begingroup$

I'm wondering why anti-aliasing is not working for me in Eeevee using Blender 3.6.1 (still an issue in Blender 4.0.0). See the minimal reproducible Blender file here.

Here are some examples. First, this is what I get with 256 render samples. I use the Anti-Aliasing Node which seems to not have any (visible) effect (playing around with the values, nothing happens).

Anti-Aliasing node in compositor

Compare this with the output I get using the outdated ID Mask Node:

Anti-Aliasing with ID Mask node in compositor

The edge looks much better now. Yet, this is not a real solution as this is only working with alpha values, so I can't get RGB out of this node.

I've also tried to play around with Render > Film > Filter Size but increasing the value does not give a good Anti-Aliasing result (here for 10.00px): Bigger Filter Size

Note I've seen this SO question, which didn't help me. This answer lead me to the ID Mask node. This is the UserFeedback during the development of the node in 2021. It looks exactly what I want to have: a global anti-aliasing for Eeevee getting rid of "jagged" edges.

$\endgroup$
5
  • 1
    $\begingroup$ This is related to how antialiasing works. Here you can see detailed explanation: blender.stackexchange.com/questions/17844/… I have nothing much to add. $\endgroup$
    – Crantisz
    Commented Nov 25, 2023 at 22:38
  • $\begingroup$ @Crantisz Thanks a lot for the link, that solved my problem ✅ $\endgroup$
    – Splines
    Commented Nov 26, 2023 at 0:21
  • $\begingroup$ Hi, Splines, it looks as if this is solved, and a duplicate, so can be closed? Is that OK? (I hope your bounty rep. doesn't go to waste, though.. asking about that) $\endgroup$
    – Robin Betts
    Commented Nov 27, 2023 at 11:27
  • $\begingroup$ @RobinBetts Hey, sure, I've just awarded the bounty, so you can go ahead and mark this as duplicate and close it ;) $\endgroup$
    – Splines
    Commented Nov 27, 2023 at 16:51
  • $\begingroup$ Cheers, @Splines. $\endgroup$
    – Robin Betts
    Commented Nov 27, 2023 at 16:53

1 Answer 1

1
+50
$\begingroup$

You are using a Plane with Emission material with Strength value of 100. The rendered image have blown up white pixel values of 100 per each RGB channel. Anti-Aliasing node expects as an input normalized RGB values (from 0 to 1 per channel). There are two options.

  • Save your image as PNG and apply the Anti-Aliasing to it. or
  • Use the Normalize node before Anti-Aliasing node if your intention is to keep it black and white.
$\endgroup$
2
  • $\begingroup$ Thanks a lot for the tip. The normalize node does work for black and white images. The reason I cranked up the emission strength to 100 is that a strength of 1 didn't appear white enough. Figured out that this is due to the Filmic (or the new AgX) view transform (see Color Management). For this project, I've now set it to sRGB where an emission strength of 1.0 corresponds to "full white" (#ffffff). Now, the anti-aliasing is working as expected even without any anti-aliasing node in the compositor ;) $\endgroup$
    – Splines
    Commented Nov 27, 2023 at 16:49
  • 1
    $\begingroup$ You are welcome! I also stick with sRGB - Standard View Color Management most of the time (for more stylized renders) and use the other options for complex lighting (usually in photorealistic renders) or if I like the looks :) $\endgroup$ Commented Nov 28, 2023 at 14:38

Not the answer you're looking for? Browse other questions tagged .