Although my plane is hidden, (eye disabled in outliner), it does render in the preview render when it shouldn't be happening.

I could create a new file and append the objects if it's merely a glitch, but my scene is way too big. I haven't been able to solve this issue on my own.

I attached my blend file. Thank you for your help.

enter image description here

  • 1
    $\begingroup$ Please upload your demo file on Blend-Exchange and edit your post to include the download link. $\endgroup$
    – L0Lock
    Sep 7 at 1:38
  • 1
    $\begingroup$ You could add some images to let us know how you are setting up your blend scene. And more info, the more, the better $\endgroup$
    – Emir
    Sep 7 at 2:20
  • 2
    $\begingroup$ Please do share, as suggested, otherwise we don't have enough to go on. $\endgroup$
    – Robin Betts
    Sep 7 at 7:54
  • 1
    $\begingroup$ I added more info as suggested $\endgroup$
    – nathalie
    Sep 12 at 21:38
  • $\begingroup$ From your image, it looks like you have "Preview active render layer in viewport" On, and because of that, it's giving you a preview of your final render. The option is below your viewport to the right, very close to the corner, after the pause simbol/ button ( the double "II") Turn it off and see $\endgroup$
    – Emir
    Sep 14 at 17:09

1 Answer 1


Maybe something broke in your file 🤔 When I open it, it doesn't even display anything in the render settings:

enter image description here

It keeps showing hidden objects, even new one I make myself.

A way to fix it is to make a new clean scene > select all with A > X > Delete.
Then File > Append (or ⇧ ShiftF1), navigate to your file, go inside its Objects folder, A to select all, and ⏎ Enter to confirm.

This way you have a new clean functional file:

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .