2
$\begingroup$

I downloaded 3 animation from Mixamo and added them as FBX. I "pushed them down" in the NLA editor as shown in this video: https://www.youtube.com/watch?v=uxPJbwXLqJs&list=PLtdazDa5xnOM8kSmgma8urtkKKYh27RCn&index=2

  • idle
  • two cycle sprint
  • running to stop

I aligned the 3 animations to run back to back, which works well. The animations play on the same armature at the correct time.

For the running to stop animation tho, I want the animation to start at the Y position where the two cycle sprint stops. I tried selecting the running to stop animation in the NLA editor, which makes it turn green and show that there are keyframes for every frame. I don't see anything in the dope sheet or graph editor though. In the dope sheet -> action editor, the animations are listed but I can not select them. Toggling "only show selected does not help.

Update: the visibility issue is partially resolved: it was in fact necessary to de-select "only show selected".

What remains is the translation issue.

Updated image showing curves

enter image description here

How do I translate all the keyframes of the last action along the Y axis while leaving the others as they are? Why don't I see the keyframes in the graph editor or dopesheet?

blend file

Original image

enter image description here

$\endgroup$

1 Answer 1

2
$\begingroup$

If you've enabled the Only Show Selected option you need to have some bones selected in Pose mode, then you can switch back to Object mode if you want (and if you disable Only Show Selected it shows the keyframes as it should):

enter image description here

Now in order to move the armature to the correct location, you need to select the master bone of your hierarchy (which is the first of the spline, called mixamorig:Hips), select the Z Location track in the Graph Editor (use the eye icon to isolate the track or ShiftH) and move the curve on the editor Y axis until it reaches the good position on the 3D scene:

enter image description here

$\endgroup$
6
  • $\begingroup$ That seems to work, thank you. Unfortunately I still need a hint about translating the animation. If I translate all bones in pose mode and then exit pose mode; there seems to be no effect. When I translate in edit mode, the bones keep their new position, but the mesh warps horribly. $\endgroup$ Commented Sep 3, 2023 at 15:47
  • $\begingroup$ I've edited, is it what you want? @Nino van Hooff $\endgroup$
    – moonboots
    Commented Sep 3, 2023 at 15:58
  • $\begingroup$ Excellent, I would never have guessed that the translation is needed on the Z axis. I never rotated the armature or mesh. For my understanding, I would love to know why. In any case, I'm really glad this got resolved $\endgroup$ Commented Sep 3, 2023 at 16:19
  • $\begingroup$ You want to move the master only, on its Z axis, the other bones will follow, you don't want to move all the other bones, if you do so, those that are not parented (like the controllers) will move on their own Z axis. As a side note, generally the armatures have a root bone that is the master (and the spline and controllers will be parented to it) but it doesn't seem to be the case with the mixamo armatures. $\endgroup$
    – moonboots
    Commented Sep 3, 2023 at 16:24
  • 1
    $\begingroup$ It's the own bone orientation that you need to consider, not the global $\endgroup$
    – moonboots
    Commented Sep 3, 2023 at 16:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .