1
$\begingroup$

I've been working on a project and seemingly out of nowhere, any new object I create ignores any materials, and is always grey.

enter image description here As you can see in the picture attached, the object is completely grey. I can asign them materials and even with them assigned, it still renders like that, completely grey. (In the picture, its using the brown leather material from the chair next to it). And this is happening with any new primitive, fresh and with nothing changed to it. They spawn and are like that, before I even do anything else with them.

If I duplicate any object I made before, they work properly. Its just that any new primitives I create are messed up. On creation they are already grey, instead of the default light grey/white, like the cilinder on its right, that has no material, and was created at the start. I can create new materials and asign them to any of the older objects and they work just fine same with giving them new textures.

I tried closing and opening the project again, blender too, but it keeps happening. I asume because I saved before I closed. I created a new project and everything works properly, so It's something that happened on this project.

This happens on material and rendered view. Interestingly however, I can see the texture just fine If I go to the Texture Paint workplace. But this doesnt fix the issue, since it's still messed up on render.

This is not a normal issue either. Tried flipping them or recalculating and nothing changes. Same for UVS: remapped the objects and nothing happens. They just ignore the materials and are like a void, ignore lights too.

I compared every value with an older object on the object tab, and everything seems the same.

This is not a graphics card or computer issue, I think its a setting I must have accidentally toggled with a hotkey, or something like that. I looked online for any solutions and I saw some people that reported the same issue, but never got a solution. Some suggested they were UV or normal issues, but I already tried that. Other threads were just the usual influx of people asking for computer specs and never replying again.

Again, this is something that happens only to new objects, not the old ones. As you can see, anything else displays and renders fine, just that at some point, something happened and now they are stuck like this.

$\endgroup$
2
  • $\begingroup$ Hello could you please share an object that has the problem? blend-exchange.com $\endgroup$
    – moonboots
    Sep 2, 2023 at 7:43
  • $\begingroup$ Preferably at least 2 objects.. some that have the problem, others that don't. $\endgroup$
    – Robin Betts
    Sep 2, 2023 at 7:45

1 Answer 1

2
$\begingroup$

I haven't read your description (sorry) ... it just looks like Cube is in Collection with Holdout enabled ... if it is not your case follow comments bellow your Q.

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ That was the issue. I didnt have the holdout icon enabled, had to manually show it to indeed confirm that was the issue. There was a collection called "background" that had Houldout enabled, and the new objects were being created there. From now on I'm keeping that icon enabled in the Outliner. $\endgroup$
    – Skessler
    Sep 2, 2023 at 8:07
  • $\begingroup$ Great it worked for you :) $\endgroup$
    – vklidu
    Sep 2, 2023 at 8:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .