4
$\begingroup$

I convert one edge of the mesh to a curve. I want to distribute mesh on the curve by using curve modifier but it won't space it evenly because the curve vertices aren't evenly spaced. How to fix that? enter image description hereenter image description here

$\endgroup$
2

2 Answers 2

5
$\begingroup$

An alternative to try is to use Geometry Nodes to resample the curve:

Keep in mind you won't see the circles (spheres) in the preview, I added another geonodes tree afterwards for that.

You can't apply the geometry nodes modifier on the curve. But what you can do is select the object, ✲ CtrlA, G Visual Geometry to Mesh. Then F3 and search for convert curve.

The preview node tree (you want to disable it before applying the modifiers) used:

$\endgroup$
4
$\begingroup$

Enable the built-in addon called LoopTools via menu Edit > Preferences > Add-ons > LoopTools. You can evenly space your vertices in a mesh by selecting all vertices in Edit Mode and then right click or RMB > LoopTools > Space. If you have a curve, first convert it to mesh and then do the LoopTools > Space and convert back to curve.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .