I keep having this problem even know a created a prefect cage mesh . marked sharp edges showing in the normal map and I tried every thing i know . I tried with the cage and without it , used different uv maps , deferent baking settings , applied all transforms , used non color image , 32 bit , used 8k image . and same result every time . can someone please help . thank you . ! enter image description here

here the blend file witch includes the high and low poly and the cage .


Thank you all for taking the time to look into my problem.

1: So here are the deferens in the normal map and the mesh between shaded smoothe and auto smoothe.

smooth enter image description here

enter image description here auto smooth enter image description here

enter image description here

As you can see, the shaded smooth mesh and normal map do not look professional, and the artifacts appear in the final model.

2: I have already finished the model and textures. enter image description here

but after some test renders, I find out that I need to redo these areas here compared to the real gun. and I wanted to use another UV map to reduce seams and make texturing easier. enter image description here

enter image description here

So I know that this is not how the normal map looks; this is how it is supposed to be. compare The text engravings in the old normal map and the new one

old enter image description here

new enter image description here

so I think that there is some problem in the baking it self not the mesh shading , it seems like cycles is not casting enough rays and I notice that the baking is so fast compared to old bakes. can anyone help please !

  • $\begingroup$ I'm not sure to understand, edges marked as sharp are supposed to show on the normal map $\endgroup$
    – moonboots
    Commented Aug 27, 2023 at 22:17
  • 1
    $\begingroup$ I can't tell what's wrong from the normal map image alone, which is never the best way to judge a normal map. To solve the problem, we need to see the low poly, the high poly, the material settings of the high poly, the bake settings, and the material or rendered preview of the low poly using the normal map. Assuming we're talking selected-to-active baking here. Best way to provide this info is with a file. Marking LP edges as sharp is rarely a good idea, that's one of the popular pieces of bad advice floating around on the internet. $\endgroup$
    – Nathan
    Commented Aug 27, 2023 at 22:24
  • 1
    $\begingroup$ baking should be done with the low poly shaded smooth, so it makes sense that sharp edges on the low poly, as Nathan says, is a bad idea. $\endgroup$ Commented Aug 28, 2023 at 0:17

1 Answer 1

  1. Select the low poly object (slide), press / for local view.
  2. ⭾ Tab, 2, A, $\color{#888}{█0}\color{green}{█}$ right-click, choose "Clear Sharp". ⭾ Tab
  3. Click in the Outliner on the high poly object (slide high) to select it, then ✲ Ctrl$\color{green}{█}\color{#888}{0█}$ left-click on the low-poly object (slide) in the outliner, to add selection and make the latter active.
  4. Disable the Cage, set related settings to defaults except use a slight extrusion of 1 cm:

  1. Create a new image in the Image Texture node, set color space to non-color, disconnect Normal Map node from Principled BSDF to get rid of circular dependency, hit the "Bake" button. When finished, reconnect the normals.

1024×1024 result:

4096×4096 result:

With better UV unwrap (aligning edges horizontally/vertically, reusing UV space) you can get better results using the 1K resolution - compare 1st rib with other ribs below:

Also the thinner your triangles get, and the smaller resolution you use, the more you need to scale them up so they don't share pixels with other geometry. Consider increasing the poly count to improve the shapes of the triangles…

20 triangles above, 30 below

  • $\begingroup$ THANK YOU @markus von broady . I have tried your solution but the problem is not fixed . PS : I have added more details about the issue if you want to take another look , I would really appreciate it $\endgroup$ Commented Aug 29, 2023 at 13:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .