0
$\begingroup$

Good afternoon,

I have recently run into an issue where my scene files no longer have the textures link to where they were before. (F:\Assets\DMP\Active_Assets) The models all seems to load fine, but my HDRI's and the textures just don't seem to show up. When I navigate to the texture file it is auto-linking to the O:/ drive now.

I know I can re-link missing files, but the scenes are huge and this can take up to two hours for it to search the entire directory.

I have also tried mapping the F:/Assets/DMP as an 'File path' in the preferences and still nothing.

I also moved all the folders of the missing files as a test to all sub directories under F:/ as well, but it still doesn't work.

The files just seems to NOT want to load up the texture files from F:/ anymore.

Note: I can see the F:/ drive fine in explorer and inside of Blender. If the directory didn't work, I would lose all the other assets in the library as well. We also have other people using the same directory for other software and it has worked no problem. This is only happening inside of Blender.

We run our entire work environment off of Virtual Machines and all storage is done over the network O:/ and F:/

Anything that I had on the O:/ drive is totally fine.

Thanks!

Note #2: It looks like anything that I have the saved file on O:/ with the textures on F:/ is broken. But anything that was saved on F:/ with textures also in F:/ seems to work fine.

$\endgroup$
2
  • $\begingroup$ have you tried creating a simple blend file on O:/ and add an image texture that links to F:/. will this simple setup also not work? so maybe some permission issue on that drive. Also check the console (Go to menu Window > Toggle System Console) to see if there are errors. Btw do you accept a solution that transfers the blend file to F:/ and then use a python script to automatically change all O:/ paths to F:/? $\endgroup$
    – Harry McKenzie
    Commented Aug 26, 2023 at 0:49
  • $\begingroup$ blender.stackexchange.com/a/56689/19307 $\endgroup$ Commented Aug 26, 2023 at 1:01

0

You must log in to answer this question.

Browse other questions tagged .