0
$\begingroup$

I have the same problem as this thread. Black borders around video output?

No idea why my 3840x2160 rendered OpenExr solution has this. I am using blender 3.3.0 with Evee engine.

I have locked the camera to view.I can see the resoulution in the source information in video editing as 3840x2160, but I don't think it is. Because when I try to zoom in to fit the video on editing it loses quality and becomes grainy.

Any help will be much appreciated.

FYI. I am a new blender user. Apologies if this is a basic setting somewhere I missed. Thanks

enter image description here

Update

This is what I mean by locking camera to view. I did this to get the camera view correct.

camera view setting

Pressing F12 gives me the right view without any black borders enter image description here

If the black border around the video image sequence is just the preview setting, I would not expect the same in the rendered MP4 video right?.

This is my image sequence with the right resolution showing up. image sequence preview

However, what the rendered video is showing is the black border.

Here is the Blender files and the video output.

$\endgroup$
2
  • $\begingroup$ The camera view locking is irrelevant for this. But when you want us to investigate what is going wrong with rendering your video, you should upload a file that uses the settings you are showing us here which may lead to the issue. The screenshots show a video strip in the sequencer and the output settings are set to FFmpeg Video. But your file is without anything in the sequencer and output set to create the OpenEXR image sequence. If I just create the image sequence (where the images have no black border) and create a video myself, there is no black border so I cannot recreate your issue. $\endgroup$ Commented Aug 23, 2023 at 6:16
  • $\begingroup$ Apart from that, the video player you are using is not the Blender internal player which opens when you hit Ctrl+F11 so I do not know how it plays videos. But if I use any other video player, I can zoom the video smaller and larger and when it is smaller than the player window, of course it shows black borders around the video - because there is nothing there when the video is zoomed out. Maybe you could upload the finished video which has the borders together with the Blender file that created the video? $\endgroup$ Commented Aug 23, 2023 at 6:19

2 Answers 2

1
$\begingroup$

//EDIT: Now that I got your file I see what happened there. The image sequence strip is scaled to 50%, if you select the strip and go into the sidepanel of the Sequence Editor, under Transform you can see Scale X and Y are set to 0.500. A strip is not necessarily always filling the full output size, for example if you want to overlay a smaller image over a background sequence and that's why you can scale it different from the output size.

This most likely happened to your sequence because Blender's output resolution is set to 1920×1080 by default. When you added the image sequence then, it was scaled down to fit the render size. When you changed the output resolution to 3840×2160 afterwards, the image sequence kept the scale of 50%. This was not always the case, in older versions the strip automatically adjusted to the new output size. The annoying thing was that when the strip had a ratio of 16:9 and you changed the output to something like 1:1 or 3:2, the clip was stretched and changed its original ratio, which was not always desired as default behavior.

scaling of image sequence

Old answer, maybe someone else can find useful information in here:

The black area is simply the window space outside of the image size. If your image strip was smaller than the complete render size, it would either show most obviously a transparent area where it is not filling the space (as long as there is no image strip below which would then be visible) when Color & Alpha is enabled in the preview or you would at least see a thin dashed line where the actual image border is if only Color was enabled (as it is in your screenshot, but maybe the dashed line is not visible because it is out of the window's bounds):

color & alpha

only color

Since you only show the Preview image in the sequencer and not how it looks when you render an image by hitting F12 and if there are still black borders (which is what is shown in the question you are linking to, the rendered output not the preview), I would suppose this is the solution to your black border problem.

About the quality of your image sequence I cannot say anything without examining the files myself, however if you probably have set the percentage in the Output Properties to something lower than 100%, perhaps because you want to render your 3840×2160 images with only 50% or 25%, then the preview image will not change the size it is displayed, but show a zoomed in image in the same size but with a lower resolution.

In the following examples I've put a 1920×1080 movie strip into the sequencer which is previewed in 1:2. The Output Properties are set to render a resolution of 1920×1080 at 100% in the first screenshot. To demonstrate the effect of changing the percentage I have set it to something very low like 10% in the second screenshot. While the preview keeps the same display size, the resolution is reduced drastically in the second image:

100% preview

10% preview

If nothing of this helps with your issues then it's probably best if you upload your file to invesitgate further what is going on there.

$\endgroup$
5
  • $\begingroup$ Please see the update section as I could not add images on comment section. I have also linked the Blender file if it helps. Thanks. $\endgroup$ Commented Aug 22, 2023 at 19:14
  • $\begingroup$ @MerrilMathew The way it is now is not helping, no. See my comments under the question. $\endgroup$ Commented Aug 23, 2023 at 6:24
  • $\begingroup$ Sure. I was not sure which files. I have now added the image sequencer blender file and the output video. here is the link. thanks @Gordon Brinkmann $\endgroup$ Commented Aug 23, 2023 at 18:23
  • $\begingroup$ @MerrilMathew I've edited the answer now that I see your problem. $\endgroup$ Commented Aug 23, 2023 at 18:54
  • $\begingroup$ Thank you @Gordon Brinkmann. That fixed the issue. Much appreciated :). $\endgroup$ Commented Aug 23, 2023 at 19:36
0
$\begingroup$

Screenshot of Corrected settings

On my video, the input frames (all 13,080 of them) were 3840x2160, and the output resolution was set to the same, yet I still had the black, or alpha channel around the edges of the render. I started going through settings tabs until I found the Transform tab on the Strip settings. By default the Scale for X and Y were set to 0.5. I changed it to 1 on both, and now it renders just fine.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .