0
$\begingroup$

I added a Bezier curve to my project and then tried to extrude it into a solid object using geometry nodes like this:

enter image description here

However, the result looks like this. The shape is what I expected, but the shading is all wrong. (It looks similarly weird in a rendered view.)

enter image description here

I guess this is because the normals are not correct, or some similar issue. What is causing this, and how can I fix it within the geometry nodes setup?

I am also happy to learn about alternative ways to achieve a similar result (using geometry nodes).

$\endgroup$
0

1 Answer 1

1
$\begingroup$

You need probably Set Shade Smooth node and uncheck?

enter image description here enter image description here


For smoothing just a curvy part and keep sharp edges you can follow this answer, that is using native Auto Smooth feature, but there are some rules to get it work.

Or you can try a Split Edges node to get the same result (that can work in some scenarios) ...

enter image description here enter image description here

$\endgroup$
1
  • $\begingroup$ Ah, great, thanks. I'd tried toggling shade smooth in the GUI but hadn't thought of doing it in geometry nodes. $\endgroup$
    – N. Virgo
    Commented Aug 21, 2023 at 14:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .