1
$\begingroup$

I'm trying to bake a combined image texture for curtains, but the result has random shadows in wrong places. I checked every object, everything unneccessary is disabled for rendering, normals are facing the right way, there is nothing overlapping and no unapplied modifiers. Don't know what else could be causing this. (I separated parts for baking). Ignore the unconnected image texture.

enter image description here

$\endgroup$
2
  • $\begingroup$ Maybe your unwrap is not correct and you have overlapping UV faces? Try to unwrap again, for example with the Smart UV Project option $\endgroup$
    – moonboots
    Aug 21, 2023 at 15:04
  • $\begingroup$ True, that was the problem! Thank you so much! $\endgroup$ Aug 22, 2023 at 13:30

2 Answers 2

0
$\begingroup$

Check to see if your ortho camera has clipping too high. Also recalculate the normals on those meshes.

$\endgroup$
2
  • $\begingroup$ I don't even have a camera and I said already that all normals are facing the right way :) $\endgroup$ Aug 21, 2023 at 13:56
  • $\begingroup$ you're right I was lazy and I apologize for not reading the post. It looked like clipping, from the image you posted. There's a bake setting for distance, but I recall that was for baking to another mesh. sorry I couldn't help. wish you the best. $\endgroup$ Aug 21, 2023 at 22:44
0
$\begingroup$

You have overlapping UV faces, it creates a baking problem, unwrap again, for example with the Smart UV Project option.

$\endgroup$
2
  • $\begingroup$ Yup, another commented the same and I tred it and it helped! Thank you. $\endgroup$ Aug 22, 2023 at 14:42
  • $\begingroup$ Yes it was me ;) $\endgroup$
    – moonboots
    Aug 22, 2023 at 14:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .