0
$\begingroup$

When I press the generate rig button, only the jaw is create properly , the others are just like an armature is (they are bones) so I can't animated my character.

I searched everywhere on Youtube but I don't find anyone fix this problem.

In this image I just select the rig rigify generated with the armature, as you can see the rig is just like my armature except for the jaw

In this image I just select the rig rigify generated with the armature, as you can see the rig is just like my armature except for the jaw

$\endgroup$
13
  • $\begingroup$ I'm afraid we need more details than that! For a start, what are you actually trying to use Rigify on? - Without any images or being able to look at your Blend file it's impossible to help you. You can share your file via blend-exchange.com if it's under 30Meg in size following the instructions there to copy the link to your question into the field on that page and it will then appear in your question. $\endgroup$
    – John Eason
    Aug 19, 2023 at 18:25
  • 1
    $\begingroup$ Have you looked how to use Rigify to begin with? It looks like you customized the metarig with no regards to how it actually works. You can't just create any bones you want and have Rigify figure out what they each are supposed to generate, you need to use premade limbs or create and define new ones using Rigify's way of functioning. There are plenty of tutorials online to generate custom rigs with Rigify, you can also look at Rigify - Advanced Usage — Blender Manual $\endgroup$
    – L0Lock
    Aug 19, 2023 at 18:32
  • $\begingroup$ @JohnEason The blender file is to big even with unnecessary things ... I add a photo of what I try to rigify . Can you tell me what informations do you need because I don t know what should i give you . Also is the file with just the armature will help you because i think the file will be under 30 Meg . Thank you ! $\endgroup$
    – Nijoyk
    Aug 19, 2023 at 21:47
  • $\begingroup$ @L0Lock Yes , I watch many tutorials on YouTube and I just use a Human rig for my rigging . Then I add samples like a jaw , a simple chain , and a tongue so everything come from rigify . If you want anything more just tell me and I will answer you ! Thank you ! $\endgroup$
    – Nijoyk
    Aug 19, 2023 at 21:52
  • $\begingroup$ Have you seen CG Dive's series on rigging anything with Rigify? - That would be my first stop! $\endgroup$
    – John Eason
    Aug 19, 2023 at 23:18

1 Answer 1

0
$\begingroup$

Preamble

I have to take back some words:

Rigify doesn't have either of a "jaw", "tongue" nor "simple chain". There is a "faces.super_face" sample that provides an entire face's rig, but you can't pick apart bits of it: it's all or nothing.

This was back in v2.81. In the current 3.61 we do have move rig types for facials in Rigify:


Source: Rig Types — Blender Manual 3.6

All the items in the "skin" and "face" categories were added back in v3.0 as part of the new standard face rig for Rigify: #89808 - Adopting a new standard face rig for Rigify - blender-addons - Blender Projects


A few issues in your rig that make things go wrong: the orientation of the armature, the rig types declaration, and a few things about general rules of rigging. Let's go through them:

Armature Orientation

If you select your armature in Object Mode and look at its rotation, you will see it rotated 180⁰:

enter image description here

This means, even though it looks like your armature is facing the front side of the world, it is actually facing the back side. If you set it back to 0⁰, you would see what the armature really looks like.
And therefore, when you generate the Rigify rig, the result is the face controllers facing backwards:

enter image description here

With your armature facing forward, select it in object mode, and press ⎈ CtrlA > Apply Rotation. This will set the current rotation as the new zero rotation.

If you generate the rig again, it faces the correct direction:

enter image description here

But now you should notice most your limbs are missing from the generated rig, which leads us to rig types declaration.

Rig Type Declaration

As you can read in its documentation, Rigify uses rig types to identify what is in the metarig and what to do with them.

Right now, aside from your facial elements, none of the bones in your metarig have rig types, hence they don't generate anything.

If you add another metarig in your scene, ↹ Tab into Pose Mode and select any first parent of a bone chain (I.E. thigh.L), you can see in the Properties Editor > Bone data tab > Rigify Type panel a bunch of information and settings:

enter image description here

The Rig Type is what tells rigify what the chain is supposed to be, and the settings bellow it depend on the rig type and will influence the rig generation. No rig type, and the chain is ignored.

If you look at your rig's thigh.L, there's nothing set up:

enter image description here

Plus, some of the bones you have are incorrectly placed: Feet are too high, fingers are twisted and don't have a slight curvature to let the IK system know in which way they must bend, ...

enter image description here

You can fix this two ways:

  1. manually declare the rig types and their settings for each chain (thighs, fingers, spine, arms, etc) by copying the settings from a clean default metarig, then fix your bones twisting and placements.
  2. Delete all bones except the facial ones that work, add a new clean metarig, delete all its facial bones, join the old metarig object into the new one, and rearrange their position to your model.

Since you are not familiar with Rigify, I would suggest the last option, as it should be the most foolproof:

  1. ↹ Tab into edit mode and select only your custom facial bones, hit ⎈ CtrlI to invert your selection, and X > Delete Bones.
  2. ↹ Tab into object mode. Press ⇧ ShiftA > Add Armature > Human (Meta-Rig).
  3. Tab into edit mode to select and delete the facial bones. That includes the face bone, but not the spine.xxx bones:
    enter image description here
  4. ↹ Tab back to object mode, select the old metarig, then ⇧ Shift select the new metarig, and press ⎈ CtrlJ to join the selected objects to the last selected. Some of your bones will disappear: that's because they were on layers that the default metarig doesn't show right now:
    enter image description here You can simply ⇧ ShiftLMB LMB these two layers to display them.
  5. ↹ Tab into edit mode, now is a good time to give your custom bone a proper name instead of just "Bone". To make sure your facial bones are all on the same and correct default layer, select them all, hit M and click the first layer as they should be:
    enter image description here

If you generate a rig at this point (I just scaled down the body's bones in edit mode so to fit them to the facial bones level), it will look like this:

enter image description here

Now all that's left is to move the bones to adapt them to your rig,

A few things to keep in mind:

  • bones must face the same direction. You shouldn't rotate them on their local Y axe. You can turn on the armature's Axes display in Properies Editor > Armature tab > Viewport Display panel > Axes.
  • IK chains (like fingers, spine, etc) need to be bent in a single direction so that the IK solver knows which way it is supposed to bend. That's why kneed are a little forward and elbows a little backwards. You must to the same for the fingers and spine. If you bend them in the wrong direction or multiple axes, you will get unexpected results when moving IK controllers.
$\endgroup$
2
  • $\begingroup$ Thank you so much for your time and for solving my problem ! I don’t know how to thank you enough ! I think I’ll should go back to study more . What you taught me is precious and I keep in mind this lesson for the future ! $\endgroup$
    – Nijoyk
    Aug 21, 2023 at 11:45
  • $\begingroup$ Just take it slow. Baby steps get you far ;) $\endgroup$
    – L0Lock
    Aug 21, 2023 at 17:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .