0
$\begingroup$

When I add texture to the text, only the edges of the text are covered, but the front and back of the text are distorted. While on the default cube, for example, the texture works correctly on all sides! where is the problem from?!

$\endgroup$
1

1 Answer 1

0
$\begingroup$

Deafult cube has UVs created already, Blender text object might not give you the results you want by default, try by converting the text to mesh; Right click > Convert to > mesh (note that this won't let you edit the text anymore), then create UVs for your text and apply the texture.

Other workaround for this is to setup the material propperly to project the texture by using a different method, a simple setup for this could be to use texture coordinate and mapping nodes, tweak the texture coordinate option that better matches the text. (this last method will let you edit the text without converting it to mesh)

$\endgroup$
1
  • $\begingroup$ Alejandro Nevárez Lucio thank you so much... $\endgroup$
    – Ali Sayah
    Aug 19, 2023 at 20:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .