0
$\begingroup$

I am trying to create some Minecraft renders, and am trying to use Joey C's BlockBlender addon based on geometry nodes. Everything appears to be working, however on the viewport, the textures appear to be banding/stretching. The UVs appear to be in place and the addon itself has been tested before and no one else seems to be encountering this issue, but using the lighter free version of the same addon does not have the same issues and the blocks appear normally. The full version's texture file size is 14304x16 while the free version is 512x16. I use a 1050ti and 16 gigs of ram.

UV editor output textures

texture above (very small) ^^

Edit: The addon seems to be irrelevant in this case. I have a .BLEND file containing the geometry node as well, and even without the addon, the issue seems to be Blender being unable to render the pixel textures itself. When I apply the texture itself onto a new file and apply it on a default cube, the problem still exists. The addon and the geometry nodes function as required. So far I have pinpointed the issue down to the texture size itself, as using other images with the same dimension replicates the same issue.

fresh file, texture applied on default cube Applying the same texture in a new file on a simple cube has the same issue as well. Single UV Map The original file only has a singular UV map

Screenshot from Frog's file

$\endgroup$
5
  • $\begingroup$ That's a third-party addon. Have you read the FAQ or asked the author? $\endgroup$
    – John Eason
    Aug 16, 2023 at 20:40
  • $\begingroup$ Yes I've already checked the FAQ as well as the author on their discord. However we came to the conclusion that the issue exists in my PC. The addon seems fine, and the geometry node also seems to be functioning as required, however its just the textures that seem to not work. $\endgroup$ Aug 16, 2023 at 22:02
  • $\begingroup$ I doubt anyone here can help in that case. Good luck. $\endgroup$
    – John Eason
    Aug 16, 2023 at 22:18
  • $\begingroup$ Hi, aliens... Welcome to BSE. If it's any comfort to you, this does look like a single point of failure, in scale / translation of mapping, or the scale of your object. To help you with it, we'd have to dive into a 3rd-party add-on. We can't do that, because we'd have to know about way too many add-ons :) ... So the right route is the one you've already followed, sorry, we can't help, here. $\endgroup$
    – Robin Betts
    Aug 17, 2023 at 8:28
  • $\begingroup$ Ah, really sorry to hear that. As a latch ditch effort, the addon does exist as a .blend file as well since it's just a custom geometry node. However, I have found something that may be helpful. Even if I apply the larger texture (14304x16) itself to a default cube (fresh file, no addon), and adjust the scale, UV, and mapping, the problem still persists. The smaller version, however, when applied, works perfectly. I am wondering if this is due to my hardware. For reference, I am using a 1050ti. All my drivers are up to date as well. $\endgroup$ Aug 17, 2023 at 13:20

1 Answer 1

0
$\begingroup$

"**The smaller version, however, when applied, works perfectly. I am wondering if this is due to my hardware . . . **"

A 14304 x 16 pixel image is 228,864 pixels, which is even less than a 512 x 512px image at 262,144px. So I don't think it has any thing to do with your GPU.

It looks like it is more to do with having more than 1 UV map for the cube. Your first screenshot is showing that the UV's for each of the cubes faces are mapped to a 2 x 2 pixel square in the UV editor instead of the 16 x 16px they should be mapped to.

I don't know anything about the add-on that you are using but I would suggest that you check how many different UV maps are being used for the cube. In the screenshot below you will see that my cube has the option to use 2 different UV maps and the rest of the Blender is set up to display something like in your screenshot,the UV editor is showing that the cubes faces are mapped to 16x16px squares but in the 3D viewport the cubes are displaying only 2x2px images. enter image description here

The correct UV map was selected from the list but because the little camera icon for that UV map was not selected it is using the other UV map in the 3D editor( Camera icon selected = Active in Render. Set the UV map as active for rendering)

If we now select enable the camera icon for the correct UV map then the cubes faces will display the correct 16x16px mapping of the image texture. enter image description here

A second option would be to connect up a UV Map node and select the correct UV map from there. enter image description here

And just to show how the other UV map has the cubes faces mapped to 2x2px squares in the UV editor: enter image description here

I am hoping the above will help you sort out what is going wrong when you are using the Joey C's BlockBlender addon.

When opening your defaultcubeminecraft.blend file everything is displaying on the cube faces as expected. Only thing a little strange is that the Minecraft image squares are not 16x16px but 14x14px and each image square is overlapping its neighbour! See screenshot below : enter image description here

Looking more closely at your screenshots 2 are showing correct 16x16px squares being used but one of them is like the one you packed in this .Blender file, 14x14px, 1px transparent strip top and bottom and with the overlaps?

$\endgroup$
6
  • $\begingroup$ Hi Frog, thanks for the answer! Unfortunately this does not seem to be the case :') The file only has one UV map and includes a UV node using the same map. I am still relatively inexperienced in Blender, but I think I've followed the instructions you've given me to my best abilities. I tried experimenting with it further on a fresh file, and when I'd use the same texture on a default cube, and applied the UV mapping, the problem still persists. In this case, there's no addon, no shader. Just an image file and a cube. I'll attach the screenshots to the original post. $\endgroup$ Aug 19, 2023 at 15:03
  • $\begingroup$ Can you share your new .blend file of a simple cube with the 14304 x 16px texture? You can upload and add it to your original post using this link blend-exchange.com You will have to Pack the texture into the file. To do that, in the UV editor open the Image menu and at the bottom of the menu you have the Pack option. Here is a link where you can download my simple cube mapped to a 14304x16 image Blender file and see if it is working as expected for you. workupload.com/file/BbFwfadwqQ $\endgroup$ Aug 19, 2023 at 15:53
  • $\begingroup$ Hi Frog, thanks again. Updating my post to include the file. Also, I think it might be because I'm late but the link's expired for me. Sorry, could you send it again? $\endgroup$ Aug 20, 2023 at 12:23
  • $\begingroup$ This one should be good for 3 days litter.catbox.moe/vmr8o0.blend $\endgroup$ Aug 20, 2023 at 15:02
  • $\begingroup$ The textures are displaying correctly on the cube when I opened your .blend file. See comment I have added to my answer above. $\endgroup$ Aug 20, 2023 at 17:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .