0
$\begingroup$

I have a problem in the compositor. The alpha looks kinda glitched. The only way to solve it was to convert the file to TIFF. Is this a knewn Bug in this Blender Version (3.6.1)?

When i open it in windows itself or in photoshop it looks fine. Only in Blender it looks like this.

Original Image

enter image description here

$\endgroup$
6
  • $\begingroup$ You have to use an Alpha Over node in the Compositor and either enable Convert Premultiplied in the node or set the Premultiplied factor to 1. $\endgroup$ Aug 15, 2023 at 10:48
  • $\begingroup$ That worked! Thanks alot! Because i watched a tutorial and there they didnt even used that. Just the image and then they linked it to the "composite" & "Viewer" node without any glitches at all. Thanks Gordon! $\endgroup$
    – hummingbrd
    Aug 15, 2023 at 10:51
  • $\begingroup$ You could also disable Convert Premultiplied and leave Premultiplied factor at 0, and instead plug the alpha output of the image into the Fac input of the Alpha Over node. $\endgroup$ Aug 15, 2023 at 10:55
  • $\begingroup$ Okey it still dont work. It just worked right now because i also rendered one image out as exr. Its still not working with the PNG. So yeah in that tutorial its working, going from the image directly into the viewer/composite Node. "use Alpha" is activated. Like i said when i take the png, convert it into a tiff file it works. $\endgroup$
    – hummingbrd
    Aug 15, 2023 at 10:58
  • $\begingroup$ Well, I did it with a PNG and no EXR. Just using Alpha Over node to place the PNG over either a color, another image or (if you want a transparent background) a render layer with a transparent background. I do not know what exactly you are doing. Or you have to link the tutorial to see what they are doing. $\endgroup$ Aug 15, 2023 at 11:09

1 Answer 1

0
$\begingroup$

The tutorial (I have the same course) is using an older version of Blender. As you can see in the screenshot in your comments, the Image Sequence node does not even have a field below the Color Space option where you can switch the Alpha.

To use the alpha channel of the PNG image, you can plug it into a Set Alpha node with the default Mode: Apply Mask. The Image output then produces an image with "correct" transparency.

set alpha

By the way, if anyone is interested in the tutorial on compositing, Martin has uploaded that part as a free tutorial on Youtube where he is using Blender version 3.0.0 Alpha: Introduction to Compositing in Blender

As you can see there, his transparency looks the same as yours before he is using Alpha Over nodes with Convert Premultiplied enabled:

alpha in tutorial

$\endgroup$
2
  • $\begingroup$ Okay thanks! Yeah the Tutorial is with an older Version but i will also check out his free Video you linked! Thanks Gordon its working now with the png! $\endgroup$
    – hummingbrd
    Aug 15, 2023 at 12:10
  • $\begingroup$ @hummingbrd Glad I could figure it out. If it helped you, you might consider accepting the answer so other users can find it, too. $\endgroup$ Aug 15, 2023 at 12:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .