7
$\begingroup$

I'm trying to edit keyframes in an existing animation in a .dae file I have imported to Blender 2.68a, however none of the changes I make seem to stick. I select the bone in pose mode, change the rotation and/or location and then insert or update the keyframe, however when I move to another frame my values are lost and the bone resets. Its as if the keyframe was never set, I can see the new keyframe however in the dopesheet.

I've applied an armature to a cube in the same file and animated it in the usual fashion and everything works fine so I'm assuming it is a setting or issue to do with the setup of the imported Collada mesh. None of the keyframes appear to be locked, and no settings jump out at me immediately as being the cause.

Google hasn't been much help, however I did find the post below where the OP seems to be having the exact same issue as me, unfortunately he didn't seem to find an answer.

animation problem - losing pose on an inserted keyframe

I feel like it is potentially something really simple I am missing. Unfortunately I can't post the file itself as I purchased it and can't freely distribute it, I have attached an image showing my file setup however.

enter image description here

Has anyone come across a similar problem?

$\endgroup$
3
$\begingroup$

The problem seemed to be that the imported collada file had multiple sets of clones of the same keyframes - 5 in my case. I'm not sure if this is a problem with the current collada import script or just with certain files, but I managed to fix the file by deleting all but the last set of cloned keyframes for each bone via the dopesheet. Once this was done I could successfully change the Quaternion channels and keyframe them as per normal. The imported animation is preserved and now editable.

mu

$\endgroup$
  • 1
    $\begingroup$ The best way to find out would be to create a very minimal setup to test, one bone with a simple animation on it (ie. just rotation or translation). $\endgroup$ – jesterKing Sep 19 '13 at 20:12
  • $\begingroup$ @jesterKing Absolutely, I have only have access to blender unfortunately and I have a feeling the model has been exported from max or maya as a collada, and that may be the issue. I'll try a blender export to collada and then re-import it and see if I can replicate the problem. $\endgroup$ – Marcus Gorillius Sep 19 '13 at 23:58
1
$\begingroup$

This can be caused when the imported animation is using Quaternion rotation. This setting is in 3D view > Properties panel (N) > Transform, and Properties > Bone > Transform > Rotation mode (visible in your screenshot):

enter image description here

Unfortunately setting this the more commonly used XYZ Euler will cause the Quaternion rotation channels to be ignored.

One workaround could be animating the rotation type to Euler whenever you want to insert keyframes, then animating it back.

There should be a way to convert between them, but it seems that there is no way to do this in blender currently (at least none that I know of)

$\endgroup$
  • $\begingroup$ Thanks for your answer, so this is a bug or the intended functionality? (I'm assuming the former) $\endgroup$ – Marcus Gorillius Sep 18 '13 at 23:41
  • $\begingroup$ @MarcusGorillius I think it's by design, but I might be wrong. Ideally, there would be a way to convert between rotation types, but I can't seem to find out how. (it is possible) $\endgroup$ – gandalf3 Sep 19 '13 at 1:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.