0
$\begingroup$

I'm new to physics in blender so I apologize if this is a trivial problem.

I'm trying to make a sphere slowly push through a wall of bricks in zero-G. I set the individual bricks to Rigid Body, and applied Rigid Body to the sphere as well. But when I try to keyframe the sphere's forward movement along the Y axis, it snaps back into its original place in frame 1.

As a workaround I tried creating a "pusher" object behind the cube to scoot it along, set that to passive rigid body, and it just goes right through the cube and the bricks. Setting it to Active also didnt help.

How can I achieve what i'm aiming for? Seems weird that such a simple idea is so difficult to get to work.

enter image description here

File:

$\endgroup$
5
  • 1
    $\begingroup$ You need to enable "animated" on the sphere's rigid body settings. $\endgroup$
    – Nathan
    Commented Aug 10, 2023 at 0:12
  • $\begingroup$ doing that causes the sphere to not interact with the bricks $\endgroup$
    – h_sharp327
    Commented Aug 10, 2023 at 0:27
  • $\begingroup$ Then there's some other problem in addition, but unfortunately, we can't tell you what it is with the info provided in this question. $\endgroup$
    – Nathan
    Commented Aug 10, 2023 at 2:06
  • 1
    $\begingroup$ Please share your file: blend-exchange.com $\endgroup$
    – moonboots
    Commented Aug 10, 2023 at 5:40
  • 1
    $\begingroup$ A share would help folks spot the problem much more quickly than a discussion .. please edit one into your post, as suggested. $\endgroup$
    – Robin Betts
    Commented Aug 10, 2023 at 9:36

1 Answer 1

1
$\begingroup$

As Nathan wrote, you have to set "animated" that you can keyframe a rigid body. Of course the animated rigid body need two keyframes so that it really "moves". is it possible that you have a third keyframe on your sphere? unfortunately you didn't show us any of your keyframes nor your rigid body settings so we can just guess.

I made a small demo blend file, how it could work, hopefully it helps:

Animating a rigid body collision with keyframes?

result:

enter image description here

the left box is animated and has two keyframes for location. The others have just rigid body active (cubes) and passive (ground)

$\endgroup$
5
  • $\begingroup$ I have it set up like your demo, the cube (now a cone, i changed the shape for a tapered look) has two keyframes to move it, but it just passes right through the bricks. I've been trying to upload the file for awhile now but it's taking forever $\endgroup$
    – h_sharp327
    Commented Aug 10, 2023 at 21:51
  • $\begingroup$ I've uploaded the blend file, would appreciate anyone who takes a look and tries to see what's wrong $\endgroup$
    – h_sharp327
    Commented Aug 11, 2023 at 6:16
  • $\begingroup$ i am not 100% sure but i would say your file is corrupt. I just added a plane as rigid body object and it didn't move at all. Did you ever remove your rigid body world or changed the collections? $\endgroup$
    – Chris
    Commented Aug 11, 2023 at 7:29
  • $\begingroup$ proposal: open a brand new blender file and append your objects. Then it works (at least i did this with your bricks and they started to fall down, which yours didn't which is awkward) $\endgroup$
    – Chris
    Commented Aug 11, 2023 at 7:31
  • $\begingroup$ yeah, i also appended your cone and it worked as expected: [2]: i.sstatic.net/m00sw.gif so i can just assume you played around with collections/remove rb world (which when i did that, i had similar problems) and that made your file corrupt $\endgroup$
    – Chris
    Commented Aug 11, 2023 at 7:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .