0
$\begingroup$

everyone! First post.

I have this very simple material node setup which both displays in Viewport Shading mode and renders in Eevee perfectly fine with no problem. In Cycles, however, all I get is a black silhouette.

The culprit appears to be the Attribute node at the end, which is feeding the Vector property into a simple Checker Texture. I kept the scene minimal so that the screenshots plainly lay out everything happening in both the Shader Editor and the Outliner (i.e., hardly anything) for you to see.

I need this mapping setup in order to dynamically texture a revolve/lathe surface built with the Screw modifier applied to a curve, as shown in the top screenshot pair.

For simplicity, however, further down below, I've included another pair of screenshots that illustrate the same issue using the default Torus primitive.

Mapping applied to a Screw surface rendered in Eevee (top) and Cycles (bottom) Mapping applied to a default Torus primitive rendered in Eevee (top) and Cycles (bottom)

$\endgroup$
3
  • 1
    $\begingroup$ As a side note, your Material Output node has only Eevee set, but that seems not to be the root cause. $\endgroup$
    – taiyo
    Aug 8, 2023 at 23:21
  • $\begingroup$ @taiyo I believe that is precisely the problem. $\endgroup$
    – gcs_dev
    Aug 8, 2023 at 23:24
  • 1
    $\begingroup$ @gcs_dev Unfortunately not. The node's target set to Eevee only hides the real problem. $\endgroup$
    – taiyo
    Aug 8, 2023 at 23:49

2 Answers 2

4
$\begingroup$

In your material mat the target option of the Material Output node is set to Eevee thus the Cycles rendering appears black. So first set it to Cycles or All. But this just hides the real problem, because then only Color2 of the Checker Texture node is rendered. You need to add the name of the attribute you want to access, for a nice list see the answer in this post. If you write uv into the name field, it will work for Cycles but unfortunately not anymore for Eevee. But if you create a UV map and write that name into the name field, it works for both renderers.

enter image description here

$\endgroup$
1
  • $\begingroup$ Great catch on my oversight there in the Output compatibility drop-down, guys. Thanks so much, @taiyo for the perfect answer. $\endgroup$ Aug 9, 2023 at 1:26
1
$\begingroup$

Your Material Output node is set to Eevee so will display black in Cycles. Switch it to either Cycles or All.

$\endgroup$
1
  • 1
    $\begingroup$ This does not work, try the setup. Even with the Material Output target set to All it will only output Color2 of the checker texture. $\endgroup$
    – taiyo
    Aug 8, 2023 at 23:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .