1
$\begingroup$

As a newcomer to Blender, I'm facing difficulty understanding why the metal texture on my object doesn't wrap smoothly, unlike another similar object that someone else textured for me.

I'm using the same texture in the same .blend file. Can anyone point me in the right direction?

I would like it to look like this: enter image description here

but instead it looks like this where you can see the individual torus faces: enter image description here The geometry looks very similar. enter image description here

Update

Adding shade smooth and autosmooth as @L0Lock suggested got me pretty much all the way there:

enter image description here

my Shader tab for the material in question for completeness: enter image description here

Any suggestions on how to further improve the appearance of the threads so they are completely smoothed like they where machined? enter image description here

$\endgroup$
3
  • 2
    $\begingroup$ You mention a metal texture, but all I see is a reflective material with what I guess is the reflections of the environment texture from the viewport's material shading mode. Though your issue looks more like a geometry concern, in object mode try using Right click > Shade smooth, check whether autosmooth is enabled (and if it is, make sure the angle setting is at least 30) and if not working, try adding a Weld modifier. Otherwise, could you provide a screenshot of your shader nodes please? $\endgroup$
    – L0Lock
    Aug 1, 2023 at 16:04
  • $\begingroup$ Normal map strength that is too high can also have similar effects $\endgroup$ Aug 1, 2023 at 17:07
  • $\begingroup$ Thank you @L0Lock, that was super helpful! I've updated my question with the results after smoothing and included a screenshot of the shader nodes for this metal material. Any more tips would be amazing :) $\endgroup$
    – buildxyz
    Aug 2, 2023 at 20:32

1 Answer 1

0
$\begingroup$

Firstly, you can set the object's shading to Smooth via the RMB RMB menu.

I like to use the Shade Auto Smooth on shapes like yours because instead of smoothing everything, it will keep the sharp corners flat shaded:

enter image description here

Then, if you have sharp edges that you want to smooth, you can either:

  1. Crank up your object's auto smooth angle under Properties Editor > Object Data tab > Normals Panel: enter image description here But it will affect the whole object. enter image description here

  2. Use a Bevel modifier (set to either target an angle or a vertex group) to change a given part of geometry: enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ awesome! thanks so much! $\endgroup$
    – buildxyz
    Aug 5, 2023 at 0:22
  • 1
    $\begingroup$ My pleasure :) Please use the vote buttons at the top of an answer to mark it helpful, and even click the ✔️ button if it's what answered your question. $\endgroup$
    – L0Lock
    Aug 5, 2023 at 1:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .