0
$\begingroup$

I'm trying to put the bear logo on my jacket's sleeve. I put the UV maps of the jacket (UVMap) and logo (UVMap.001) in the shading and mix them together. Also, I added a new UV map and unwrapped part of the jacket for the logo. However, they couldn't mix together in the flat viewpoint shading.

When I select the jacket UV map, the preview shows the jacket UV with the jacket UV on the sleeve.

Image1enter image description here

When I select the logo UV, the jacket will become transparent with a logo on the sleeve.

Image2enter image description here

It is successful to see both UV in the lighting shading mode.

Image3enter image description here

I am making an anime character with flat color so I don't know if it affects the final look if I use lighting mode. Although there are two different UV maps, the mesh of the sleeve shares the same area of both UV maps and I don't know how to separate them.

Image4enter image description here Image5enter image description here Image6enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Hm that shader tree looks correct. Maybe try different Alpha methods for your bear head texture. Otherwise, could you please do file > external data > pack all into file, save a new file with the Compress option on, and upload it on Blend-Exchange and edit your question to add the download link please? So that we can check what's going on in your scene. $\endgroup$
    – L0Lock
    Jul 31, 2023 at 1:02
  • 4
    $\begingroup$ @L0Lock Not necessary to upload a file. Jess: You are using the Texture option in the Solid shading mode. This does not show combined textures, therefore you have to be in Material Preview or Rendered shading mode. How the Texture in Solid shading works I explain in more detail in my answer on this question: UV Grid appearing as solid colour $\endgroup$ Jul 31, 2023 at 9:04

0

Browse other questions tagged .