1
$\begingroup$

I have a scene where all objects have a color ramp node. When I turn off light, HDRIs, world color, and so on, I still see objects in color. I want that when all lights are off and I render the image, to not see nothing in render. The scene is a night club and only lights I want to see are the ones I made, everything else should be in dark or close to.

As you can see in picture. There are 2 cubes. The blue cube has a color ramp and it renders blue. There is one more cube between the blue cube and my scene that doesnt have color ramp and in render you can not see it. I want to achieve the same thing for my other objects and make only my lights shine on thementer image description here and give them color and visibility.

This is Node tree for pretty much every object. I'm using Eevee.

enter image description here

$\endgroup$
8
  • 3
    $\begingroup$ When you think it has something to do with the Color Ramp node, would it be too much to ask that you also show us the shader nodetree of at least one of those materials so that we can see if there is something causing this behaviour? And maybe you could also tell us if you are using Cycles or Eevee (although I think it's not essential in this case)? But if you are not using a very very old version, this is surely not the old Blender Internal render engine which you have put in the tags. $\endgroup$ Jul 28, 2023 at 6:35
  • 4
    $\begingroup$ You need to put a shader (Diffuse or Principled BSDF) just before the Output, otherwise the image or the ColorRamp will be emissive, I guess this is your problem here but as Gordon says it would be useful to see a screenshot of your Shader Editor $\endgroup$
    – moonboots
    Jul 28, 2023 at 8:09
  • 1
    $\begingroup$ Please show your shader node-trees $\endgroup$
    – Robin Betts
    Jul 28, 2023 at 16:59
  • 2
    $\begingroup$ As @moonboots said, you need to plug that color data into a shader node before instead of the material output. Any color data plugged in the material output is treated as an emission (raw color only) shader. You can use a simple diffuse shader or a principled, it doesn't matter. Also for simplicity and performance sake, you probably don't need a principled shader plugged into your shader to rgb node, I bet you don't use any of these settings aside the color, a diffuse shader there would be simpler and tidier. $\endgroup$
    – L0Lock
    Jul 28, 2023 at 19:10
  • 1
    $\begingroup$ The reason "color ramp" seems to be an issue is that it doesn't go from black to whatever color, it starts at a somewhat bright color, so when there's no light, the "shader to RGB" generates black, but then it's translated to non-black by the color ramp. BTW, "Color Ramp" has been renamed and since B3.6 has a space between "color" and "ramp" in its name. $\endgroup$ Jul 28, 2023 at 20:30

1 Answer 1

1
$\begingroup$

You need to put a shader (Diffuse or Principled BSDF) just before the Output, otherwise the image or the ColorRamp will be emissive.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .