0
$\begingroup$

My 3d object doesn't render. Only the tracked footage appears when I try to render the scene. What could be the problem ?

Layout Render

Here's the .blend file. https://drive.google.com/file/d/194iS-WFTLlGNtrLZ-7vMW65P0wfpIX3R/view?usp=sharing

Thanks in advance.

$\endgroup$
2

1 Answer 1

2
$\begingroup$

The problem is, in the Output Properties under Post Processing > Pipeline the Sequencer is enabled. This is by default and usually no problem when you create a 3D scene and want to render it, as long as there is nothing in the Sequencer.

sequencer in pipeline

But you have a strip with a movie clip there, so the Sequencer determines what the output shows - and there is no strip for the scene. The problem now is, you can press Shift+A > Add > Scene, but the only option available there is "New Scene", you cannot choose the active scene in which you are in.

add new scene strip

To do this, you have to create a new scene with the New button next to the scene name. I would not copy the original scene but start with a completely new scene.

create new scene

If you now go to Video Editing and try to add a scene strip, there appears the name of the other scene ("Scene") to choose it as input. This way you can have many different scenes where you create 3D contents and additionally have one scene only for the video editing. In your case you have to add the movie clip there as well of course.

add existing scene strip

If you just want to render your object to see how it looks and do not care for the movie clip, you can disable the Sequencer in the post processing pipeline while you render.

If you do not want to use the Sequencer from the Video Editing at all, you can go there, delete the strip containing the movie clip and since it's the only one, your scene will now be rendered normally. To get the movie clip in the background you can add it in the Compositor and use an Alpha Overlay node to composite the 3D scene above it.

$\endgroup$
4
  • $\begingroup$ Hey @Gordon Brinkmann could you copy paste this answer over to blender.stackexchange.com/questions/53632/… ? Feel free to ping me there for a free upvote $\endgroup$ Jul 26, 2023 at 8:22
  • $\begingroup$ @DuarteFarrajotaRamos I did post it there now as well, but I saw the reason I give in my answer is already there, only that their solution to that is a bit simpler... just disabling the sequencer. $\endgroup$ Jul 26, 2023 at 8:30
  • $\begingroup$ Yes, yours is a little more thorough, that is why i think it is a good addition. Thanks for posting! $\endgroup$ Jul 26, 2023 at 8:43
  • 1
    $\begingroup$ It worked ! Thank you so much :) $\endgroup$ Jul 26, 2023 at 9:53

Not the answer you're looking for? Browse other questions tagged .