4
$\begingroup$

I've applied the 'Subdivision Surface' modifier to my plane, but the subdivisions only appear when I'm in Wireframe View? I also cannot seem to select individual faces in Edit mode either.

I've toggled with various buttons, including Optimal Display, On Cage, GPU Subdivision in Preferences, but to no luck unfortunately.

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ I was just writing an answer when you posted yours, well I gave it anyway because there is an additional mode to show the wireframe. But your question was unclear, you did not say you wanted to see the wireframe in Object Mode explicitly (because "Wireframe View" could be in Edit Mode as well). What is confusing me in your screenshot though is that the plane should show the subdivisions there, since the modifier has the display options Edit Mode and On Cage enabled and Optimal Display disabled... even if set to Display As > Bounds they should show up in Edit Mode. $\endgroup$ Jul 26, 2023 at 6:14

2 Answers 2

8
$\begingroup$

Of course you cannot select the subdivided faces as long as the modifier is not applied, because the modifier is procedural and creates only "virtual" geometry, it is not real and can be changed anytime by changing the subdivision levels for example. You have to be careful with the terminology here to avoid misunderstandings: your title and question say, you have "applied" a modifier on the plane while you actually just added a modifier to it. "Applying" a modifier in Blender means, creating real geometry from the modifier's settings and removing the modifier, thus making the changes to the mesh permanent and no longer changeable.

Seeing the wireframe in Object Mode can be achieved in two ways:

  1. Per object by enabling Wireframe under Object Properties > Viewport Display.
  2. For all objects by enabling Wireframe in the Overlays for the 3D Viewport (the Opacity setting there effects the per object wireframe as well).

Note: If an object is set to Display As > Bounds in the Viewport Display options, it will only show the bounds and no wireframe, no matter where you enabled it (in Object Mode, but the mesh will be shown in Edit Mode).

Also an object with a Subdivision Surface modifier will not show the subdivided wireframe as long as Optimal Display is enabled in the modifier settings, no matter which method you choose.

wireframe settings

$\endgroup$
0
$\begingroup$

I can only select/edit individual faces after applying the modifier to the mesh. If I want to view the subdivided grid outside Edit Mode, I need to go to Viewport Display on the bottom right, and check the Wireframe Box.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .