0
$\begingroup$

I'm trying to learn UV mapping and here's the thing: in one case it just doesn't show in UV editor, there's only a properties window (as you can see on the screenshot of the clock below)

screenshot of the clock

and in another case, it shows too many parts (see the screenshot of monitor's UV)

screenshot of monitor's UV

I've already checked the vertices (by clicking M > Merge by Distance) and normals (by clicking on Face Orientation), applied scales and orientation... everything is just fine but UV still doesn't work the way it should.

The link to blender file is here

Any help is highly appreciated, thanks!

$\endgroup$
4
  • $\begingroup$ It's allowed to attach. In fact in many cases helpful. Use blend-exchange to upload and paste the generated text. Use the edit option under the question. $\endgroup$ Jul 24, 2023 at 11:30
  • 1
    $\begingroup$ I don't understand, why people insist having wrong statements as their question titles like "UV mapping does not work" It does work. One might not know how to do it, but it certainly works. A title should reflect the question. $\endgroup$ Jul 24, 2023 at 11:37
  • $\begingroup$ @Akshay2005 Thanks for the tip, question is updated. $\endgroup$
    – Pigalle
    Jul 24, 2023 at 11:41
  • $\begingroup$ In the answer that I have provided, I have mentioned about the holes getting stretched in a wierd way if you use the UV squares addon. If you do face that problem I would suggest you to ask it as a seperate question. Coz I haven't figured it out myself yet. Also if you do find my answer helpful and correct, please consider accepting it once you solve your issue. And best of luck with your learning. $\endgroup$ Jul 24, 2023 at 12:28

2 Answers 2

2
$\begingroup$

About the monitor screen, there is overlapping geometry and some of probably even seeperate from the geometry. First clean it up. enter image description here

This is one of the reason behind the wierd UV map.

Since this geometry is more like a cube, unwrap it like a cube. (unwrapping it in the wrong way is the second reason for the wierd UV map) enter image description here

I honestly don't know why the clock was not unwrapping. But the classic technique of deleting and making a new one worked. I deleted the UV map in the object data properties panel. Created a new one and it worked perfectly fine. Where you place the seams is the obviously the most important thing in UV unwrapping. This one too is like a cube(more like a cylinder). Unwrap it the same way.enter image description here

But one thing I realized is that you have modelled the feet into the clock itself. Nothing wrong about that. But you will have to be more careful.

Place the seams as shown in the following pic. enter image description here

You will get a UV map like this. enter image description here The long curly strip is the curved surface.

The 2 circles are the front and back circles.(Use the free UV squares addon if you want to straighten it. Be careful about the holes as they may get get stretched in a wierd way.)

The 2 remaining things are the legs.(Notice how I have unwrapped them like a cube as well)

You have a lot to learn. Identifying what type of object is the first and most important step in order to place seams correctly and thus having a good UV map.

$\endgroup$
4
  • $\begingroup$ Yes, deleting UV map worked for the clock, thanks! As for the monitor screen, I checked all the vertices again and deleted the copy of the object that was somehow built into it. Then I marked the seams the same way as in your pic but UV map is still the same (like this - ibb.co/30zNqsW) $\endgroup$
    – Pigalle
    Jul 24, 2023 at 14:00
  • $\begingroup$ The duplicate faces are still there. The wierd glitchy thing appearing on the surface is the sign. $\endgroup$ Jul 24, 2023 at 14:05
  • $\begingroup$ This is strange, because the program itself tells me that there are no double vertices here... I deleted the duplicate object manually and got the right UV map after all. Thanks a lot! $\endgroup$
    – Pigalle
    Jul 24, 2023 at 14:50
  • $\begingroup$ There are faces overlapping where it's curved. There are no double vertices. The under lying faces are sharing the vertices with the faces above it. That is exactly what I have shown in the first image. You can go to edit mode and turn on x-ray (alt+z) and using face select mode, delete the faces below. To be honest since it's such a simple piece of geometry, if you want to save time, remodelling is going to be a better option. However if you are just learning, just continue with the cleanup. $\endgroup$ Jul 24, 2023 at 15:01
0
$\begingroup$

You have to follow 2 steps only:

  1. Mark seams( Ctrl + E -> M ).
  2. Unwrap( U -> U ).

enter image description here

As you can see it, Blender will automatically try to unwrap the surface of the mesh cutting on your marked seams. You can chose 2 different algorithms after the operation:

enter image description here

Conformal may give better results for more straight, non-organic forms. You can always test both to see what works best for the specific object.

If you mark seams that cannot be used for unwrapping, you will obviously get bad results. If you get bad results, it usually means your marked seams are not good enough.

I don't really know what's wrong with your file. It seems as if the UV data got somehow corrupted. You can simply delete the UV map and create a new one:

enter image description here

$\endgroup$
3
  • $\begingroup$ Yes, I know how UV is supposed to work and I've already done these 2 steps. But, as I said before, in one case UV simply doesn't appear in UV editor and in another case it gives obviously wrong results. I also tried to mark different seams but nothing's work here. That's why I'm so confused, just don't know where is the problem. $\endgroup$
    – Pigalle
    Jul 24, 2023 at 11:54
  • $\begingroup$ You are a fast learner. In the post you were only learning it, but now you know. :D Try deleting the UV map in the Data tab of the Properties editor and then creating a new one with the + button. The seams in your file are still not going to give very good result. You should choose more adequate places for them. $\endgroup$ Jul 24, 2023 at 12:09
  • $\begingroup$ The thing is this is a result from a tutorial and my seams are the exact copies of the ones in that tutorial. But thanks anyway, because deleting UV map worked for the clock. Unfortunately, it didn't work for the second object... $\endgroup$
    – Pigalle
    Jul 24, 2023 at 13:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .