After using the Boolean modifier to cut two eye holes on the head mesh, and then I realize that in Cycles render, the reflection and shadow are all jagged:

enter image description here

By the way, I have tried "Boolean Clean up" from the add-on "MeshMachine v0.13" to merge the vertices located on the cutting area, but this does not changed the jagged line shown on the reflection and shadow.


1 Answer 1


After performing boolean operations on a mesh, in almost all cases you are going to have n-gons or trainagles near the border. These n-gons and tris create a lot of nasty shading issues. Sometimes though, if you want the border to remain sharp, then just enabling auto smooth solves issues most of the times. If the border is going to be subdivided or something in the future, a cleanup of the border is compulsory. There is a lot of content regarding n-gons and shading issues available online. So I won't explain that.

To enable auto smooth, go to Object Data properties > Normals > Check Auto Smooth. Alternatively it can be enable while in object mode by right clicking the model and selecting "shade auto smooth".

This is the result I got after enabling auto smooth on both the meshes: enter image description here

  • $\begingroup$ A great answer! Because I don't understand the difference between "Shade Smooth" VS "Shade Auto Smooth", I always right click mouse -> "Shade Smooth", which did not remove the jagged line. Your answer is telling me that "Shade Auto Smooth" should be used. Then I find that a YouTube from Blender Secrets said that "Shade Smooth" and "Shade Auto Smooth" should both be used in many cases. However, I still don't understand the difference between them, except you can control the parameter for the angle of the face normals when using the auto smooth. $\endgroup$ Jul 21 at 3:20
  • $\begingroup$ (A simplified explanation) Auto smooth smoothes out surfaces below the angle threshold set by the user. ie If the threshold is 30 deg, then wherever the angle between the faces is less than 30 deg smoothing is used, otherwise it retains the flat look. (Also auto smooth works only in blender and if you ever want to export the model you should use things like support loops and subdivision modifier) $\endgroup$ Jul 21 at 3:36
  • $\begingroup$ But this did not explain what angle between the face normals are used for the "Shade Smooth". I expected that the angle would be 360 - meaning that if any angle between the face normals had been less than 360 deg, then the shade would have been smooth. But obviously, from this example, I see that this expectation is wrong. That is why I still do not understand the difference between "Shade Smooth" and "Shade Auto Smooth". Some related discussion is here: blender.stackexchange.com/questions/55975/… $\endgroup$ Jul 21 at 3:57
  • 1
    $\begingroup$ I will add a self answered question later today. I hope that will clear it for you. $\endgroup$ Jul 21 at 4:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .