1
$\begingroup$

I have a thin "string" mesh with only line of vertices and gave it a Skin Modifier for it to have some thickness. I enabled Cloth physics for it with Self Collision, and pinned the left most vertex. The other right end has a vertex hooked to an Empty. Then I have a thick plane as Passive Rigid Body with Collision physics enabled for it. If I press space to start the simulation, the string cloth falls right through it.

The weird thing is that if I add another plane, and then Shift select the string and do Ctrl+L > Copy Modifiers, which makes it the same cloth as the string and then play the simulation, the plane cloth will actually collide with the passive rigid body. So why does the string which is the original holder of those modifiers not collide with the passive rigid body?

enter image description here

These are the settings for the passive rigid body and then on the right, the settings for both string & plane cloths.

enter image description here

Why does the plane cloth collide but not the string cloth despite its modifiers being copied from the string cloth? How do I fix this in Blender 3.6?

$\endgroup$
1
  • $\begingroup$ first (most important) hint: cloth collision does only work with faces, not with edges $\endgroup$
    – Chris
    Jul 20, 2023 at 8:06

1 Answer 1

1
$\begingroup$

as i wrote in the comment, if you change your romantic text mesh and extrude in on z-axis:

enter image description here

then delete your cloth and add it again to get default settings and just add the pin group, you will get:

enter image description here

$\endgroup$
3
  • $\begingroup$ thank you for looking into this! i found out that actually you just have to delete the the subdivision and cloth modifiers and then add the cloth modifier and subdivision modifiers again. then it works. no need the z-extrusion. so basically the skin modifier had to come before the cloth. but for some reason you can't just swap them. you had to manually delete them and add them again in swapped order $\endgroup$ Jul 20, 2023 at 11:43
  • $\begingroup$ this will make the render slower - i think - because then you will have more geometry by the skin modifier ;) and by moving the skin modifier up, you have "faces" which can collide, what i wrote ;) $\endgroup$
    – Chris
    Jul 20, 2023 at 11:58
  • 1
    $\begingroup$ I'll mark this one as the answer so we can also close it. Thank you! $\endgroup$ Jul 25, 2023 at 2:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .