0
$\begingroup$

[EDITED] Using cycle mode, I am trying to get a mask image of the rendered object which object index layer.

But when compared with the "composite" layer, "object index" layer does not seem to mask the rendered object correctly.

e.g.

Combined layer enter image description here

Object Index layer enter image description here

I set Alpha Threshold to 0 but there is no effect.

How can I get a mask image covering the combined layer correctly for any pixel with alpha > 0?

$\endgroup$
3
  • $\begingroup$ Why don't you multiply the object pass with the alpha pass ? $\endgroup$
    – Gorgious
    Jul 18, 2023 at 13:22
  • $\begingroup$ @Gorgious What do you mean? Multiplying alpha channel of combined layer to the object pass layer? $\endgroup$ Jul 18, 2023 at 23:22
  • $\begingroup$ Yes, and set a Greater than to filter out the threshold at which you don't want the object pass to appear. Blender doesn't know whether you want alpha between 0 and 1 to be considered as object pass or not $\endgroup$
    – Gorgious
    Jul 19, 2023 at 7:47

1 Answer 1

0
$\begingroup$

It's prolly 'cause of Cycles render. Try to increase noise threshold also amount of samples and turn off denoise

render properties.

Also, keep in mind how Cycles render works, and you might consider using Eveee for that kind of thing. In addition, try to increase light paths value like about 2x times and see what happens. light paths properties

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .