0
$\begingroup$

I am currently doing my first steps with sculpting. I am trying to turn a half-icosphere into a donut-like object using the SculptDraw brush and the "subtract" mode. However, I cannot seem to remove geometry beyond a certain plane, I always end up with something like shown below, and cannot subtract more geometry. The hole does not get deeper and just flattens out.

I have tried various sculpting tools, settings and stroke methods, but the hole just flattens out at some level of depression. What am I doing wrong here?

Update/more info

  • "Accumulate" does not fix the issue
  • cannot reproduce behavior in a new model
  • I am not trying to punch a hole. Maybe "deep crater" would have been a better description than "donut". The issue is me being unable to move the vertices further "in"

Screenshot

$\endgroup$
4
  • $\begingroup$ Is the question incomplete? Because after "What am I doing wrong here or" you have written nothing and closed the sentence with a question mark. $\endgroup$ Jul 17, 2023 at 23:49
  • $\begingroup$ Are you accidentally clicking shift? Because when you hold shift while making the stroke, the smooth brush is gets activated. $\endgroup$ Jul 17, 2023 at 23:52
  • $\begingroup$ The question is complete, it just had an unnecessary "or" at the end - edited. $\endgroup$ Jul 18, 2023 at 4:27
  • $\begingroup$ Shift/smoothing is not active $\endgroup$ Jul 18, 2023 at 4:28

1 Answer 1

1
$\begingroup$

You won't make any hole-donut thing in sculpt mode in blender. It's just that in how sculpting works in CG. You're just making brush stokes with alpha onto the surface and change its appearance, not actual "geometry". Sounds funny, but that is :) So in yo case you gotta need make a hole by deleting vertices manually in edit mode. enter image description here

After that you need to make there a tunnel by selecting edges and click "bridge loops" enter image description here

And only after that you gonna remesh a whole thing once more, before you got this nice-looking hole

Edited! Make sure you have that option checked on whenever you need to push your brush over and over to surface

enter image description here enter image description here Why is that fixing it? As I mentioned earlier, when you sculpt you don't change actually geometry, like what you do in edit mode or other stuff. You just displace the geometry so that changes its appearance.(even if it looks like that changing) Hard to explain it in two words, but think about sculpting in Blender as drawing a normal map in textures. And ones you displace curtain area one time with same "power" of a brush, another that same "power" wouldn't do anything. So in that case they added feature that changing layering mode to smth like "multiply" in other turms. So it doesn't add a new same brush stoke, but multiplies previous one with a new one, so you could see progress. Hope I make it clear, ain't native speaker of English, sry :)

$\endgroup$
4
  • $\begingroup$ I was going to tell this to him later. But this is not the problem he is facing. The problem (according to what I understood) is that he is not able to push the vertices further. $\endgroup$ Jul 18, 2023 at 7:20
  • $\begingroup$ @Akshay2005 oh, I see. Thx, i've forgotten about one more useful feature in that case. He just needs to "accumulate" brush enabled. Just edited my post :) $\endgroup$ Jul 18, 2023 at 7:27
  • $\begingroup$ Do you know why that fixes it? If you know, can you add it to the answer please? I have never encountered such an issue before so I am curious. $\endgroup$ Jul 18, 2023 at 7:31
  • $\begingroup$ I have tried activating the "accumulate" option (even before making the post). It does not help. Strangely, I cannot reproduce the issue in a new model. Good point about the "hole"/topology but as Akshay mentioned, that is not the problem here. Also, in a new model I can push indefinitely deep without the "accumulate" setting $\endgroup$ Jul 18, 2023 at 9:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .