0
$\begingroup$

enter image description here enter image description here

By enabling the Subdivision modifier, the newly generated vertices are twisted in a weird way as shown on the screenshot. Why?

Reason: Although points D and C are connected by an edge, the points ABCD do not form a face yet, and the points CDEF do not form a face either. Instead, the points ABEF do form a larger face.

Question: Is there any quick way to form faces for the points ABCD and the points CDEF, and delete the face for the points ABEF please? (The less number of mouse clicks are required to achieve this goal, the quicker and the better method it must be.)

BTW, on the screenshot 2, only 2 vertices are selected. After enabling the Subdivision modifier, 14 vertices are highlighted automatically on the screenshot 1. This is because the addon called "Draw Xray" by bartoszstyperek was turned on. The addon does not affect the end result, and is supposed to only provide a better visual experience in the viewport.

$\endgroup$
8
  • $\begingroup$ Although Chris provides an answer for the mesh as it is now in the file you provide here, for future modeling it might be helpful for you to know how you can avoid a problematic geometry like you have here. Since you did not tell us how you got from the first screenshot to the second, I can only guess the CD edge was created by selecting those vertices and pressing F. This connects the vertices, but freely without connection to the face (i.e. by splitting the face). Therefore you have to press J as Chris suggests. $\endgroup$ Jul 17, 2023 at 7:07
  • $\begingroup$ And to get from screenshot 1 to screenshot 2, you should probably get used to using shortcuts like M for Merge vertices either by what was selected or distance etc., also double G for Edge Slide (and maybe Auto Merge enabled). $\endgroup$ Jul 17, 2023 at 7:09
  • $\begingroup$ @GordonBrinkmann , yes, your guess is right - the CD edge was created by selecting the two and pressing F. Getting from the screenshot 1 to screenshot 2 was easy - just disabling the Subdivision modifier can get from the screenshot 1 to screenshot 2. $\endgroup$ Jul 17, 2023 at 8:17
  • $\begingroup$ That's not what I mean, disabling the modifier disables the smoothing effect - but in the first screenshot there are 14 vertices selected, in the second one there are only two. Which means you must have applied he modifier although it is still shown to be there. This is why I thought the first one was the original mesh and you reduced it to the second one to clean it up a little. But you see - this is why I said I do not know how you got the second mesh. At least there must have been vertices before and for some reason you first created a large face and then connected vertices inbetween... $\endgroup$ Jul 17, 2023 at 8:32
  • $\begingroup$ @GordonBrinkmann , no cleaning up was done, and no modifier was applied. In the screenshot 2, select those two vertices, and then enable the Subdivision modifier, so that 14 vertices are select automatically. $\endgroup$ Jul 17, 2023 at 8:42

1 Answer 1

2
$\begingroup$

Hopefully this is what you wanna have:

Select the two vertices, press X -> Delete -> Edge. Select the two vertices, press J.

Done.

enter image description here

$\endgroup$
3
  • $\begingroup$ Looks promising. I'll try later to test if your method can apply for a large mesh with a numerous amount of these problems in one shot. See ya soon. $\endgroup$ Jul 17, 2023 at 6:18
  • $\begingroup$ For a larger mesh with a numerous amount of the same problem (for example the mesh attached in my question), enter into the "edge" editing mode, then click "Select" -> "Select All by Trait" -> "Loose Geometry". Then all edges without connections to a face will be selected in one shot. Then press "X" to delete these edges. However, pressing "J" to re-form new faces has to be done one by one, so that it can't be done in one shot. $\endgroup$ Jul 17, 2023 at 8:11
  • 1
    $\begingroup$ @BlenderLake No, this cannot be done in one shot, how should Blender guess which ones you want to connect? That's why I asked how you got this messy geometry, you must have done something wrong while creating it. It is often better to get it right in the first place then to clean up afterwards. But without knowing what you did it is not easy to tell you what to avoid. $\endgroup$ Jul 17, 2023 at 8:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .