0
$\begingroup$

I was working on a scene, in EEVEE, the shadows looked great, and after working on the geometry for a while, I noticed the shadows look jagged and really low-res. Here's the comparison between an older version that looked fine and the current jagged version :

Normal shadows Jagged shadows

I still have the same Render settings with the Cube size and Cascade size set at 4096px.

When I copy all my new models in the old file, the shadows look fine, so it has to be a setting on my new file that broke the shadows. Is there another setting I might have missed and changed by accident that changes the quality of the shadows?

I figured out it was a problem with my camera because if I import the old camera into the new file, the shadows look fine. I'd still like to know what causes it because AFAIK every setting between the two cameras are similar.

I added a minimal file that shows the problem, you can switch between the two cameras in the Scene tab, and you'll see the issue :

$\endgroup$
2
  • 1
    $\begingroup$ It might be helpful to people trying to help you if you uploaded an example blend file to the site blend-exchange.com and add that link in the question. $\endgroup$
    – Rick T
    Commented Jul 16, 2023 at 13:09
  • $\begingroup$ @RickT Thanks, I added a minimal test file that shows the weird behavior. $\endgroup$
    – ttb
    Commented Jul 16, 2023 at 13:46

0

You must log in to answer this question.

Browse other questions tagged .