0
$\begingroup$

I modeled a wall light, which you can see in the images. I created a studio environment and rendered that. However i couldn't figure out why glass material looks worse when denoising is applied. Is the problem caused by my render settings or glass material itself or something else?

enter image description here enter image description here enter image description here enter image description here

$\endgroup$

2 Answers 2

1
$\begingroup$

The "smudging" effect of the Denoiser will probably disappear when you use more Render Samples; 200 for refractive Glass Lenses is maybe a bit low. Try raising the samples a good bit, maybe in steps of 100, and re-render. Repeat a few times until you get there.

Also: I assume that you have good resons to cancel out the shadows in your glass material? Because they affect the rendering quite a bit. This only has a minor impact on your main problem, but still it's something to keep in mind when troubleshooting. :-)

enter image description here Left: Your Shader. Right: Principled BSDF, 100% Transmission, 0% Roughness.

$\endgroup$
1
  • $\begingroup$ thanks for reply :) i tried what you said, still i've same problem, it didn't worked. thank you for your helps:) $\endgroup$
    – Furkan
    Jul 14, 2023 at 12:20
0
$\begingroup$

if you turn off caustics, that should lower the noise, though it doesn't really work if you want caustics. have you tried using denoising normal and albedo in the compositer?enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .