2
$\begingroup$

How can I achieve hair partings seen on animals with very thick fur, where fur parts in long vertical clumps?

sheeps wool parting

My first attempt was to cut the mesh surface into these clumps and use "part by mesh islands" in the interpolate hair strands node. However, these partings are destroyed by any clumping geometry nodes applied on top.

Mesh islands

Clumps don't seem to respect partings at all, which makes parting pretty useless. Is there an option I'm missing here? Clump size exaggerated to make the issue obvious. Any other method of achieving the sheeps fur look is also appreciated of course.

Clumps don't respect parting

$\endgroup$

1 Answer 1

4
$\begingroup$

A custom Guide Mask for the Clump Hair Curves node group should do the trick. This can be either a vertex group that you can specify in the modifier interface directly or an image texture mask.

In the example, the quick fur of Blender 3.6 was used and the Clump Hair Curves asset was added.

Option 1: Vertex Group - The vertex group must be on the surface object ("Curved Plane"). The weights require vertices (e.g. a subdivided plane ;-) and the same options as described below.

Option 2: Image Texture Mask - Because you cannot specify the image texture in the Geometry Nodes modifier directly you need to move it to the nodes editor. This is done with the dropdown menu entry "Move to Nodes" of the modifier.

move to nodes option

It creates a wrapper GN node tree with the Clump Hair Curves node group in it. In the Geometry Nodes editor you can now define the options.

Clump Hair Curves Options

  • uncheck Existing Guide Map so any existing guide map is not used (Interpolate Hair Curves creates usually one)
  • define a Guide Distance value for the creation of the new curve guides
  • connect an Image Texture node to the group's Guide Mask input

Last but not least, you need to

  • create a new group input for the modifier so you can specify the UV map of the hair curves' surface object ("Curved Plane" in the example). This is needed to map the image mask properly. (To create the input just drag the Vector slot of the Image Texture node to the empty Group Input node slot and rename it in the side panel of the editor (N).
  • define the UV map in the modifier settings ("UVMap" for the default UV map)

clumped sheep fur example requires Blender 3.5

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .